Subject: VAX vs. Alpha for OpenVMS

From: "Zane H. Healy" <[email-masked]>
Date: Thu May 22 01:32:01 2003

OK, a bit of an odd question here, but I'm wondering what people think as I'm used to a PWS 433au.

A co-worker of mine just bought a VAXstation 4000/90 and a DEC 3000/400.  She wants to use one of them as a Mail Server running OpenVMS.  The VAX looks to have 104MB, the Alpha looks to only have 96MB.  Any idea on which would work best for her?  Part of what has me concerned is the lack of RAM on the Alpha.  If she uses the VAX, it will probably end up running V7.3, if the Alpha probably V7.2-1H1.  DECwindows won't be loaded, which will help get the Alpha down to a better memory footprint.

Oh, she'll probably also want to run a Webserver on the system so that the mail can be accessed via the web.

			Zane
-- 
--
| Zane H. Healy                    | UNIX Systems Administrator |
| [email-masked] (primary)    | OpenVMS Enthusiast         |
|                                  | Classic Computer Collector |
+----------------------------------+----------------------------+
|     Empire of the Petal Throne and Traveller Role Playing,    |
|          PDP-10 Emulation and Zane's Computer Museum.         |
|                http://www.aracnet.com/~healyzh/               |

---

From: "Zane H. Healy" <[email-masked]>
Date: Thu May 22 03:39:00 2003

>Oh, she'll probably also want to run a Webserver on the system so that the mail can be accessed via the web.

Make that a VAXstation 4000/60.

		Zane

---

From: Jochen Kunz <[email-masked]>
Date: Thu May 22 03:43:00 2003

On 2003.05.22 08:30 Zane H. Healy wrote:

> A co-worker of mine just bought a VAXstation 4000/90 and a DEC
> 3000/400.  She wants to use one of them as a Mail Server running
> OpenVMS.  The VAX looks to have 104MB, the Alpha looks to only have
> 96MB. 
The DEC 3000-[456789]00 need very special 100 pin 40 bit ECC SIMMs. One
memory bank consists of 8 SIMMs. This gives a memory bandwith of
[viewing ek-d3sys-pm.ps.gz] 427 MB/s (model 400) to 640 MB/s (model
800). That is a lot for a 10 year old design. The low end DEC 3000-300
are in the range of 200 MB/s to 329 MB/s. 96MB is not much for an
Alpha...

The VS4k90 maxes out at 128 MB RAM. Are you sure it has 104 MB RAM? The
VS4k90 has 8 SIMM sockets and one bank consists of 4 SIMMs. It needs
special 80 pin ECC SIMMs. It can take 4 MB or 16 MB SIMMs. So the
machine can have 16, 32, 64, 80 or 128 MB RAM. 

Maybe it is a VS4k60? The VS4k60 has 8 MB on board and 6 SIMM sockets.
It takes the same RAM as the VS4k90 and one bank consists of 2 SIMMs. So
you get 104 MB RAM with the 8 MB on board 6 x 16 MB SIMMs. 

The VS4k60 has 12 VUPs and the VS4k90 24 VUPs (or 30, don't remember).
If it is a VS4k60, it would be best to epay some RAM for the DEC
3000-400 and use it. If it is a VS4k90, well, the DEC 3000-400 eats
about twice (!) as much electricity as the VS4k90. So if this is
importand... Depending on the load, the VS4k90 may be better as it has
more RAM and the VAX is _very_ memory efficient. 128 MB is a _lot_ for a
VAX. 
-- 

tschüß,
       Jochen

Homepage: http://www.unixag-kl.fh-kl.de/~jkunz/

---

From: Jochen Kunz <[email-masked]>
Date: Thu May 22 06:16:01 2003

> Make that a VAXstation 4000/60.
Use the DEC 300-400, it will run circles arond the VS4k60. 
But keep an eye open for more RAM.
-- 

tschüß,
         Jochen

---

From: "Antonio Carlini" <[email-masked]>
Date: Thu May 22 11:17:01 2003

> A co-worker of mine just bought a VAXstation 4000/90 and a 
> DEC 3000/400.  She wants to use one of them as a Mail Server 
> running OpenVMS.  The VAX looks to have 104MB, the Alpha 
> looks to only have 96MB.  Any idea on which would work best 
> for her?  Part of what has me concerned is the lack of RAM on 

I suspect that either would work. I run a VS4000-90A here
at home and it hums along quite nicely doing the odd compile
and running a web server. If I let the your hordes get to
the webserver I suspect the connection would die well
before the VAX!

The Alpha will be perhaps 2-3 times faster (at least
going by the SPEC numbers I can find for related 
models and guessing a little based on frequencies).

104MB is certainly enough for the VAX to happily function
as a workstation - the additional cpu and memory load 
from a webserver and mail server will be negligible
- at least for home use, I'd not plan on running a
large enterprise based on this! I forget exactly what kind of
memory the DEC 3000 took, but it's probably cheap enough
on ebay these days that it can be maxed out
if it's a problem.

Either OpenVMS or NetBSD would probably be fine for
this usage (although be sure to get the NetBSD 1.6
or so that fixed the non-fatal overwriting of
part of the console flash ... I think it was the
VS4000-9x that was hit).

I use the OSU webserver under OpenVMS and Apache
under Solaris. As a single user I'm unable to
cause either to die under load :-)

Antonio
 
-- 

---------------
Antonio Carlini             [email-masked]

---

From: Jochen Kunz <[email-masked]>
Date: Thu May 22 13:23:16 2003

> models and guessing a little based on frequencies).
Really? The Alpha has about twice as much MHz, but the 21064 is known to
need a lot of MHz per MIPS. 

> part of the console flash ... I think it was the
Yes. The dz(4) probe routine in NetBSD prior to 1.6 (1.5?) modified some
bytes in the FLASH ROM of the VS4k9x. This causes a FLASH checksum error
at startup und thus preventing autoboot but everything else works. It is
save to use 1.6 and there is a MOPable FLASH ROM update for the VS4k9x
available that repairs this. 
-- 

tschüß,
       Jochen

---

From: "Stuart Johnson" <[email-masked]>
Date: Thu May 22 14:17:01 2003

----- Original Message ----- 
From: "Jochen Kunz" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 22, 2003 11:49 AM
Subject: Re: VAX vs. Alpha for OpenVMS

<SNIP>
> available that repairs this.

Where would I find this Flash ROM update? I have several 4000-90's and would
like to know more about this.

Thanks,
Stuart Johnson

---

From: "Antonio Carlini" <[email-masked]>
Date: Thu May 22 16:03:00 2003

> Really? The Alpha has about twice as much MHz, but the 21064 
> is known to need a lot of MHz per MIPS. 

The data I have for the VS4000-90 is about 32 SPECmarks
and similar numbers for SPECint/fp89.

I don't have any numbers for the DEC 3000-400 but it
runs a 21064 @ 133MHz. I have numbers for other members
of the family that run at various speeds from 100MHz
to 175MHz, so I guessed.

There is also a chart at:
http://h18002.www1.hp.com/alphaserver/performance/perf_by_perf_dec.html

If you go by VUPs, the uV3100-95 and VS4000-90
are about equal, which would put the systems
on a par. So you pays your money and you takes
your choice.

I still think either system would have enough
grunt to do the job.

> autoboot but everything else works. It is save to use 1.6 and 
> there is a MOPable FLASH ROM update for the VS4k9x available 
> that repairs this. 

There is indeed - I remember sending one version to a few
people to recover their boxes (very brave of them to try
it since I'd never actually needed it myself!). Then
someone found a more recent version and made it
available via ftp. And then someone went and fixed
the problem.

Antonio
 
-- 

---------------

---

From: Jochen Kunz <[email-masked]>
Date: Thu May 22 16:50:01 2003

On 2003.05.22 21:12 Stuart Johnson wrote:

> Where would I find this Flash ROM update? I have several 4000-90's and
> would like to know more about this.
Grepping the NetBSD/port-vax archive gives:
http://hermes.tubas.net/vs4000-90A_firmware.zip
The ZIP contains a VS4000.doc and a cougar_v1_3.zip... 
-- 

tschüß,
       Jochen

---

From: "Stuart Johnson" <[email-masked]>
Date: Thu May 22 17:31:00 2003

----- Original Message ----- 
From: "Jochen Kunz" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 22, 2003 3:05 PM
Subject: Re: VAX vs. Alpha for OpenVMS

> The ZIP contains a VS4000.doc and a cougar_v1_3.zip...

Many thanks!

Stuart Johnson

---

From: "Zane H. Healy" <[email-masked]>
Date: Thu May 22 23:19:01 2003

>of the family that run at various speeds from 100MHz

It's about 71-75 SPECint, and I think around 110 SPECfp.

			Zane

---

From: Jochen Kunz <[email-masked]>
Date: Fri May 23 03:33:08 2003

> >and similar numbers for SPECint/fp89.
[DEC 3000-400 ]
> It's about 71-75 SPECint, and I think around 110 SPECfp.
Surprising for me. I thought that the gap was smaler.
Maybe I should run a benchmark (== building the NetBSD world) on my
machines. 
-- 

tschüß,
       Jochen

---

From: "Zane H. Healy" <[email-masked]>
Date: Fri May 23 11:27:01 2003

>Maybe I should run a benchmark (== building the NetBSD world) on my

I was in a hurry last night, here are the actual SPEC92 numbers from:
ftp://ftp.cs.toronto.edu/pub/jdd/spectable

For VUPS see (unfortunatly the later VAXen have SPECmark89, and the Alphas have SPECint92/SPECfp92):
http://anacin.nsc.vcu.edu/~jim/mvax/vax-perf.html

Amazingly my memory was very close.  My VMS server was originally a 3000/300LX, unfortunatly I can't remember if it acted as a mailserver, or if it was just serving up disks at that time.

I've included numbers from the 'spectable' file for most of the Alpha's that are listed, and are likely to be in hobbyist hands.  I've also listed the smaller VAXen in that list.

			Zane

System            CPU        ClkMHz  Cache      SPECint SPECfp  Info  Source
Name              (NUMx)Type ext/in  Ext+I/D      92      92    Date  Obtained
================= ========== ======= ========== ======= ======= ===== =========
DEC VAX4000/60    KA46       22.2    ?            11.1    12.6  Mar93 DECinfo
DEC 3000/400      A21064     27/133  512+8/8      74.7   112.2  Apr93 c.arch

DEC VAX3100/38    ?          ?       ?             3.5     3.8  Mar93 DECinfo
DEC VAX3100/76    REX520     ?       128           7.1     6.6  Mar93 DECinfo
DEC VAX4000VLC    SOC        ?       25            5.8     6.3  Mar93 DECinfo
DEC VAX4000/90    NVAX       71      2/8             ?    30.2  Sep92 SPEC news

DEC 3000/300      A21064     30/150  256+8/8      66.2    91.5  Apr93 c.sun.mc
DEC 3000/300L     A21064     20/100  256+8/8      45.9    63.6  Apr93 c.sun.mc
DEC 3000/300LX    A21064     25/125  256+8/8      63.5    75.5  May94 SPEC news
DEC 3000/300X     A21064     35/175  256+8/8      84.4   100.5  May94 SPEC news
DEC 3000/500      A21064     30/150  512+8/8      84.4   127.7  Apr93 c.arch
DEC 3000/500X     A21064     40/200  512+8/8     110.9   164.1  Apr93 c.sun.mc
DEC 3000/600S     A21064     35/175  2M+8/8      114.1   162.1  Oct93 c.arch
DEC 3000/700      A21064A    38/225  2M+16/16    162.6   230.6  Jul94 Digital
DEC 3000/800S     A21064     40/200  2M+8/8      138.4   187.6  May94 c.sun.hw
DEC 3000/900      A21064A    39/275  2M+16/16    189.3   264.1  Jul94 Digital

DEC 200/4/100     A21064     ??/100  512+8/8      74.6    95.2  Feb95 Digital
DEC 250/4/266     A21064A    ??/266  2M+16/16    198.6   262.5  Apr95 www.dec
DEC 255/233       A21064A    ??/233  1M+16/16    180.0   210.0  Mar96 Digital
DEC 255/300       A21064A    ??/300  1M+16/16    215.0   245.0  Mar96 Digital
DEC 500/266       A21164     43/266  2M+96+8/8   329.0   405.0  Mar96 Digital
DEC 500/333       A21164     46/333  2M+96+8/8   389.6   480.1  Mar96 Digital
DEC [24]00/4/166  A21064     33/166  512+8/8     116.2   134.8  Jul95 Digital
DEC [24]00/4/233  A21064A    39/233  512+16/16   157.7   183.9  Apr95 Digital
DEC 600/5/266     A21164     38/266  2M+96+8/8   289.0   405.0  Jul95 Digital
DEC 600/5/266     A21164     38/266  4M+96+8/8   292.8   433.5  Jul95 Digital
DEC 600/5/300     A21164     75/300  4M+96+8/8   337.8   502.1  Jul95 Digital
DEC 600/5/333     A21164     83/333  4M+96+8/8   412.4   545.2  Jan96 Digital

System            CPU        ClkMHz  Cache      SPECint SPECfp  Info  Source
Name              (NUMx)Type ext/in  Ext+I/D      95      95    Date  Obtained
================= ========== ======= ========== ======= ======= ===== =========
DEC 200/4/100     A21064A    ??/100  ?+16/16      1.88    2.79  Aug96 Digital
DEC 200/4/166     A21064A    ??/166  ?+16/16      2.95    3.64  Aug96 Digital
DEC 200/4/233     A21064A    ??/233  ?+16/16      4.28    4.32  Aug96 Digital
DEC 250/4/266     A21064A    ??/266  2M+16/16     5.18    6.27  Apr95 www.dec
DEC 255/233       A21064A    ??/233  1M+16/16     4.27    5.09  Mar96 Digital
DEC 255/300       A21064A    ??/300  1M+16/16     5.23    5.81  Mar96 Digital
DEC 500/266       A21164     43/266  2M+96+8/8    7.93   11.1   Mar96 Digital
DEC 500/333       A21164     46/333  2M+96+8/8    9.82   12.5   Mar96 Digital
DEC 500/400       A21164     53/400  2M+96+8/8   12.3    14.1   Jun96 Digital
DEC 500/500       A21164     48/500  8M+96+8/8   15.0    20.4   Aug96 Digital
DEC 600/5/266     A21164     38/266  4M+96+8/8    7.91   11.8   Sep95 Digital
DEC 600/5/300     A21164     75/300  4M+96+8/8    9.78   13.4   Sep95 Digital
DEC 600/5/333     A21164     83/333  4M+96+8/8    9.23   13.2   Feb96 Digital
DEC 600A/5/500    A21164     ??/500  8M+96+8/8   14.8    17.4   May97 www.dec
DEC PW433AU       A21164     ??/433  2M+96+8/8   13.9    18.1   Jul97 www.specb
DEC PW500AU       A21164     ??/500  2M+96+8/8   15.7    19.5   Jul97 www.specb
DEC PW600AU       A21164     ??/600  2M+96+8/8   18.4    21.3   Jun97 www.specb
DEC 3000/500      A21064     30/150  512+8/8      2.15    3.65  Sep95 Digital
DEC 3000/700      A21064A    38/225  2M+16/16     3.66    5.71  Sep95 Digital
DEC 3000/900      A21064A    39/275  2M+16/16     4.24    6.29  Sep95 Digital

---

From: [email-masked]
Date: Fri May 23 20:55:54 2003

On Thu, 22 May 2003, Jochen Kunz wrote:

> > The Alpha will be perhaps 2-3 times faster (at least going by the SPEC
> > numbers I can find for related models and guessing a little based on
> > frequencies).
>

Of course any NVAX-based VAX would stomp all over a 21064, but the 4k60 is
significantly slower than a 4k90.

Peace...  Sridhar