Subject: OT: Software Documentation

From: Matthew Sell <[email-masked]>
Date: Wed Mar 12 10:51:00 2003

Guys,

I work for a small consulting company that creates software for 
distribution. We're a low volume operation, and don't have many employees.

I've been trying to rein in the whole development process to streamline it 
over the last couple of years, and now I need to streamline the methods by 
which we create documentation for our products.

I'd love to know what systems people on this list use for creating software 
documentation (manuals, etc.), and I'd love to hear any recommendations for 
systems that allow for concurrent access (kinda like CVS), change approval, 
revision control, etc, etc.

Are there any good open-source solutions available? I've been searching and 
gathering information, and I'd really appreciate hearing the experiences of 
others on this list.

Thanks!

         - Matt

Matthew Sell
Programmer
On Time Support, Inc.
www.ontimesupport.com
(281) 296-6066

Join the Metrology Software discussion group METLIST!
http://www.ontimesupport.com/subscribe_t&c.html.

"One World, One Web, One Program" - Microsoft Promotional Ad
"Ein Volk, Ein Reich, Ein Fuhrer" - Adolf Hitler

Many thanks for this tagline to a fellow RGVAC'er...

---

From: Brian Chase <[email-masked]>
Date: Wed Mar 12 12:03:40 2003

On Wed, 12 Mar 2003, Matthew Sell wrote:

> I've been trying to rein in the whole development process to
> streamline it over the last couple of years, and now I need to
> streamline the methods by which we create documentation for our
> products.
>
> I'd love to know what systems people on this list use for creating
> software documentation (manuals, etc.), and I'd love to hear any
> recommendations for systems that allow for concurrent access (kinda
> like CVS), change approval, revision control, etc, etc.
>
> Are there any good open-source solutions available? I've been
> searching and gathering information, and I'd really appreciate hearing
> the experiences of others on this list.

You can use CVS in combination with either TeX, or Docbook,
or nroff, or HTML, or....  I don't think any "packaged" open
source products exist because it's easy enough to roll your
own sophisticated document production system with standard
development tools (CVS and make) combined with any number of
the dozens of freely available text processing tools.

-brian.

---

From: JimD <[email-masked]>
Date: Thu Mar 13 14:49:15 2003

Might want to look at this:
http://www-cs-faculty.stanford.edu/~knuth/cweb.html
The CWEB System of Structured Documentation. I haven't used it.
It integrates doc, design and revision control. 
Jim Davis.

Brian Chase wrote:
<snip>