Subject: Re: goin to CA soon, to be a CC tychoon

From: Ed Chapel <[email-masked]>
Date: Sun Jun 8 17:47:00 2003

>At 12:00 PM 6/8/2003 -0500,  Jim Davis, your nimble fingers typed:

>Sorry, Getting totally OT here, PC HEIDENS was considered the "SOUP
>NAZI" of the reseller world. Found their way to bankrupcy last year.. Har 
>Har.
>NO CHIPS FOR YOU!

Your analogy here is spot on...  I had to pick myself up after falling out 
my chair laughing.

---

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon Jun 9 12:48:00 2003

>From: "Vintage Computer Festival" <[email-masked]>
>
>On Sat, 7 Jun 2003, Jim Davis wrote:
>
>> You will be treated like crap at all levels of any transaction at fry's.
>> Expect, No, assume that
>> any advertised product will be out of stock, that the  pepsi machine
>> will of be of  more help
>> then the sailsdroids. Don't even think about using a check, unless you
>> have about an hour or
>> two to wait ( I AM NOT KIDDING ), Check all the packages, as frys simply
>> returns
>> defective and returned products to the shelves. Returns? Plan on
>> spending the day.
>> Need I say more?
>
>And that's on a GOOD day!!!
>

Hi
 First, one needs to realize that Fry's is a discount store.
They do everything as cheap as they can. They do not hire
sales people with computer knowledge. I don't expect them
to answer any question more complicated than "where is
such-an-such?". They are require, now, by law to mark items
that have been returned as such. Most items that have been
returned are working and have nothing wrong with them. They
do not have in store personal that can test everything in
the store.
 I often buy return items when on sale. I expect to test them
when I get them. I have only had one bad item that was re-wrapped.
They replaced it without question( they may have put it back
on the shelf ). It did take time standing in line.
 I guess it is mostly expectations. One can often find most
any of their items cheaper, someplace else. Unless you happen
to be at that someplace else, it isn't worth the gas to look
for it.
 As for people ripping them off, their biggest problem has
and always will be with the store personal.
Dwight