Subject: PDP-11 Freeware CDs for RSX-11 and RT-11 (Originally Produced by Tim Shoppa)

From: "Jerome H. Fine" <[email-masked]>
Date: Tue Apr 15 17:43:00 2003

The last two times I posted this, another person contacted
me either for help or to request the CDs.  This will be the
last time for about 6 months unless more people reply.

In regard to the Freeware CDs for RSX-11 and RT-11
that Tim Shoppa originally produced:

I am in the middle of finishing a second (very small) batch
of CDs and could easily add a few additional copies.

I will be making all copies of the CD images from:
ftp://ftp.trailing-edge.com/pub/cd-images/
http://www.classiccmp.org/PDP-11/RT-11/
http://www.classiccmp.org/PDP-11/RSX-11/

Since not everyone has both a high speed internet connection
and a CD burner, I thought it would be helpful to make them
available.  If you have both requirements and are using
Windows 98 SE / Nero Burning, I can help with the details
if you don't know how to burn a CD from an "Image File".

I have even been able to produce a label for each
CD that is close to the original label from Tim Shoppa,
although since they were scanned (THANK  YOU
FOR  THE  HELP), they are not perfect.

They are available at $ 5 / $ 9 / $ 12 for 1 / 2 / 3 CDs.

In addition, I understand that Memorex Black CD-Rs have a
longer shelf life and are available at Business Depot.  If anyone
wants those instead, add $ 1 for each CD that you are
requesting.  Thus those amounts are $ 6 / $ 11 / $ 15

Please contact me directly for my snail mail address.

I picked up some Memorex Black CD-R blanks and started
on the copies for those who have already requested that a
Black CD-R be used.

Please include your mailing address!!!!!!!!!!!!!!!!!!!

In general, I will regard any funds you send as a gift so that if
anyone really can't afford the CDs, please state why that is so.

Outside of the US, probably about $ 2 should be sufficient
for extra postage.  All amounts are in US dollars.  Please ask
if you are not in the US.  No point in converting twice.

Sincerely yours,

Jerome Fine
--
If you attempted to send a reply and the original e-mail
address has been discontinued due a high volume of junk
e-mail, then the semi-permanent e-mail address can be
obtained by replacing the four characters preceding the
'at' with the four digits of the current year.

---

From: Robert Borsuk <[email-masked]>
Date: Thu Apr 17 11:47:00 2003

Hi All,
	I'm looking for a Pascal Microengine. If anyone has one that they 
would be willing to part with ($) or if you know of someone who doesn't 
have room for one anymore, could you send them my way.  It will have a 
good home porting code and reliving an old project.

Thanks
Rob

Robert Borsuk - [email-masked]
President
Colourfull Creations
http://www.colourfull.com

---

From: "Andrew Strouse" <[email-masked]>
Date: Fri Apr 25 22:20:00 2003

I think I am interested in these CDs.  I have a few questions though.  I
apologize in advance for any "newbie" questions.  Can I use these CDs with
E-11 or simh?  Also how many different CDs are you creating? (If you order 3
are they all the same?)  Also, can you paypal?  (I would be willing to add a
service charge if you can.)  Thanks for any answers you can provide.

Andrew Strouse
( [email-masked] )

----- Original Message -----
From: "Jerome H. Fine" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, April 15, 2003 6:41 PM
Subject: PDP-11 Freeware CDs for RSX-11 and RT-11 (Originally Produced by
Tim Shoppa)

---

From: "Jerome H. Fine" <[email-masked]>
Date: Sat Apr 26 23:26:00 2003

>Andrew Strouse wrote:

> ( [email-masked] )

Jerome Fine replies:

There are 3 CDs:
(a) RT-11 with BOTH an ISO9660 and an RT-11 file structures
      The ISO9660 portion 21,223 files / 969 directories / 403,733,960 bytes
      The CD full image is 671,088,640 bytes which is 65,536 * 20
      blocks or exactly 20 RT-11 partitions with the first portion
      being files under the ISO9660 files structure and the last
      7 RT-11 partitions holding files with each of those 7 partitions
      having the necessary RT-11 file structure
      The files under the ISO9660 file structure can be accessed via
      any operating system which can.  Both E11 and SIMH are
      usefully able to "MOUNT/ATTACH" all of the individual files that
      have an internal RT-11 file structure
      On a PC using Windows 98 SE, I have tested the E11 command
      MOUNT  DU0:  CDROMa:/RONLY  where "a" is the drive letter
      which allows all 7 non-zero RT-11 partitions to be used directly
      under RT-11 (as are all the other non-zero RT-11 partitions fully
      available), BUT  E11 can NOT see for RT-11 partition zero the first
      64 blocks (of 512 bytes each or 16 CD sectors of 2048 bytes each -
      which is NOT either a problem or relevant since under the RT-11,
      they are all zero as there is NO  RT-11 directory structure for RT-11
      partition zero)
      In addition, the "Full" (Commercial) version of E11 allows the command
      MOUNT  DU0:  SCSIn:/RONLY  were "n" is the SCSI  ID
      which also allows all 7 non-zero RT-11 partitions to be used directly
      under RT-11
      AND if a user has a SCSI  CDROM drive on a real PDP-11 which
      SUPPORTS 512 byte access, then a real PDP-11 running RT-11
      can also directly use those same 7 non-zero RT-11 partitions along
      with all of the other 13 partitions which is not relevant since none
      of them have an RT-11 file structure
(b) RSX-11 with an ISO9660 file structure
      The ISO9660 file structure 55,093 files / 2040 directories / 528,559,136
bytes
      The CD full image is 610,842,624 bytes
      The files under the ISO9660 file structure can be accessed via
      any operating system which can.  Both E11 and SIMH are
      usefully able to "MOUNT/ATTACH" all of the individual files that
      have an internal RSX-11 file structure
(c) RSX-11 with an RSX-11 file structure or so I have been told
     The CD full image is 665,600,512 bytes
     I have never used this CD, but I imagine that SIMH can't at all and the
     hobby (demo) version of E11 would have difficulty using this CD
     under Windows 98 SE because the first 64 blocks are NOT available
     BUT, under the "Full" (Commercial) version of E11 the command:
     MOUNT   DU0:  SCSIn:/RONLY  where "n" is the SCSI  ID
     can use this CD with the RSX-11 file structure
     AND if a user has a SCSI  CDROM drive on a real PDP-11 which
     SUPPORTS 512 byte access, then a real PDP-11 running RSX-11
     can also directly use this CD.

I have only used the RT-11 CD.

>Zane H. Healy also wrote:
>I'm not sure about E11, but with SIMH, you should be able to 'dd' them to a
>disk image, and access the RT-11 formatted portion of the RT-11 CD from RT-11
>and the ODS-1 formatted RSX-11M/M+ CD from RSX-11M/M+.
I am not sure how I would "dd" them, but I guess I could also provide the
*.bz2 files on a separate CD as well - they would easily all fit on one CD.

Then, as required, these compressed versions can be expanded using
bzip2.exe and checked with MD5.exe for the MD5 value.  Then, while
SIMH can open these very large files, the hobby (demo) version of E11
can NOT do so.  However, the "Full" (Commercial) version of E11
is able to do so.

Sincerely yours,

Jerome Fine