Subject: Dragon 64

From: Al Hartman <[email-masked]>
Date: Thu Mar 6 10:03:00 2003

I've decided to try to get my Dragon 64 running again.

I got it from Bob Rosen of Spectrum Projects. He
stripped all the socketed chips from it, however.

So I need to find a set of Dragon 64 ROMS, and
identify what chips go in U19 and U15.

I'm pretty sure that the one closest to the ROMS is
the 6809E, but not sure of what the other chip should
be.

What makes this more difficult is that this is not a
British Dragon. This is an American one made by Tano
Corporation.

I wish I had just offered him some money for the
original chips way back when...

I can buy a whole new Dragon for $35.00 + S/H, and if
I can't get a set of ROMS and the missing chip cheaper
than that.. I may just do that and keep this one as a
spare...

I wish I still had the Dragon disk controller also...

I know I can use a Tandy Controller, but I think I'll
need a different Disk Basic ROM for it. If anyone can
help with that, I'd be obliged...

Regards,
Al Hartman

P.S.: On the Apple II pricing discussion in a
different thread. I agree with Sellam re the pricing.

The buyer could easily resell the items he didn't want
on eBay and get the prices that Sellam quoted.

And who knows if those IIGS's contain RAM boards or
even Super SCSI cards that would be work $15.00 for
the RAM card, and $40 and up for the SCSI cards.

---

From: [email-masked] (tim lindner)
Date: Thu Mar 6 11:02:00 2003

> help with that, I'd be obliged...

Lets see...

The Tandy controller/software uses the following:

 Read byte, store byte, halt CPU, un-halt CPU, repeat. NMI when done.

The Dragon controller/software uses the following:

 SYNC, interrupt, read byte, store byte, repeat. NMI when done.

On the Tandy controller DSKREG is $FF40, and the wd179x is mapped
between $FF48-$FF51.

On the Dragon controller DSKREG is $FF48, and the wd179x is mapped
between $FF40-$FF43.

Also the bit patterns for DSKREG are different between the Tandy and
Dragon controllers:

 * ---------------------------------------------------------------
 * DSKREG - the control register
 * CoCo ($ff40)                        Dragon ($ff48)
 *
 * Bit                                 Bit
 *  7 halt enable flag                  7 not used
 *  6 drive select #3                   6 not used
 *  5 density (0=single, 1=double)      5 NMI enable flag
 *    and NMI enable flag
 *  4 write precompensation             4 write precompensation
 *  3 drive motor activation            3 single density enable
 *  2 drive select #2                   2 drive motor activation
 *  1 drive select #1                   1 drive select high bit
 *  0 drive select #0                   0 drive select low bit

It would take some serious hacking to transform a CoCo FDC into a Dragon
FDC.

-- 
The ears are too length.
--------------------------------------------------------
tim lindner                    [email-masked]

---

From: [email-masked] (Tony Duell)
Date: Thu Mar 6 13:51:07 2003

> the 6809E, but not sure of what the other chip should

If it's a 40 pin chip then you might br able to do it by a process of 
elimination!

The 5 40 pin chips in a Dragon or CoCo are 6809E, 6883, 6847, 2 off 6821.

-tony