Subject: TRS80 Model 100 technical questions

From: Frank Arnold <[email-masked]>
Date: Thu May 1 09:33:00 2003

Hi all,

I got a TRS80 Model 100 in and need some technical info:

-what is the polarity of the DC-input on the socket? 

-Is a filtered 6 volt DC voltage ok or has it to be stabilised?

-I found lots of recources on http://www.club100.org/ 
even a technical manual, this however does not adress this DC input.

Thanks,
Frank

---

From: "Jason J. Gullickson" <[email-masked]>
Date: Thu May 1 10:17:01 2003

Club100 is the best source I've found, however I run my M100 using a
cheapo brick from Radio Shack that lets you select from like four or
five different voltages, so I can't imagine that it needs anything fancy
(although the battery life is pretty amazing without an adapter).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Frank Arnold
Sent: Thursday, May 01, 2003 10:32 AM
To: [email-masked]
Subject: TRS80 Model 100 technical questions

Hi all,

Thanks,
Frank

---

From: The Design Fort DTP <[email-masked]>
Date: Thu May 1 11:37:00 2003

I would be interested to learn more about the Heathkit EC-1 analog computer.
So far I only found pictures and specifications on the net. Is there a
website that actually explained how this machine worked and/or what it
could/can do. 
Even more are there informations about "programs" that this machine could
run?

I have to admit that the "analog" times of the computer age was a bit before
my time, but I really would love to learn more about it.

Herbert

---

From: The Design Fort DTP <[email-masked]>
Date: Thu May 1 11:47:00 2003

I think somebody from this list contacted me regarding my paperclip computer
project. Unfortunately I had a problem with my email-server, so this email
got deleted. Maybe this person could contact me again?

Thanks
Herbert
Computer Museum of Nova Scotia

---

From: steve <[email-masked]>
Date: Thu May 1 12:16:01 2003

there is tons of stuff on the net, try

http://dcoward.best.vwh.net/analog/

for good introductions, all analog computer are
basically the same, the biggest difference is how many
op amps they have, and that limits what you can do.
Each amp can be configured to either add, substract,
multiply, integrate etc by hooking up the appropriate
feedbacks (all the wires you see hanging off them, the
gains are set by variable resistors on the unit, the
knobs you see on the EC-1). They are used to simulate
dynamic systems, like an aircraft control system for
instance (a few hundred amps), or a weight attached to
a spring (a few amps) 

--- The Design Fort DTP <[email-masked]>
> my time, but I really would love to learn more about
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---

From: Roger Merchberger <[email-masked]>
Date: Thu May 1 12:24:01 2003

>(although the battery life is pretty amazing without an adapter).

Just had a couple messages from Rick Hanson this morning... I've known him 
(thru email) for nearly a decade, and it's damn hard to find a) a nicer guy 
in general, or b) anyone more knowlegable about the inner tickings of 
Kyocera-OEMed laptops (including the Tandy Models 100/102/200; NEC 8201a; 
Olivetti M10 & friends...)

<MODE=ShamelessPlug>
I also have a mailing list that's available WRT these machines, you can sub 
by emailing [email-masked] -- there's almost 200 people on 
the mailing list, so there's quite a following there...
</MODE>

HTH,
Roger "Merch" Merchberger

--
Roger "Merch" Merchberger -- sysadmin, Iceberg Computers
[email-masked]

What do you do when Life gives you lemons,
and you don't *like* lemonade?????????????

---

From: "Peter C. Wallace" <[email-masked]>
Date: Thu May 1 12:29:01 2003

> instance (a few hundred amps), or a weight attached to

Actually all analog computers are _not_ the same.

For example: Resistive Sheet computers are very different....

PCW

---

From: Ethan Dicks <[email-masked]>
Date: Thu May 1 12:33:00 2003

--- steve <[email-masked]> wrote:
> ... the biggest difference is how many op amps they have...
> to simulate dynamic systems, like an aircraft control system
> for instance (a few hundred amps), or a weight attached to
> a spring (a few amps) 

I was skimming this and read "Amperes" for "op amps" in the
above.  My thought train derailed at the visualization of
a multi-hundred Ampere circuit to simulate an aircraft
control system.

Good thing I wasn't drinking Dr. Pepper...  :-)

-ethan

---

From: Ethan Dicks <[email-masked]>
Date: Thu May 1 12:35:00 2003

> For example: Resistive Sheet computers are very different....

I have an idea of how an analog (electronic) computer would work
(compared to a mechanical analog computer - that's voodoo with cams)...

How does a resistive sheet computer work?

In the same vein (pun intended)... how would fluidic computers
stack up?  Digital?  Analog?  Mixed?

-ethan

---

From: "Peter C. Wallace" <[email-masked]>
Date: Thu May 1 14:02:00 2003

> How does a resistive sheet computer work?

	The one that I saw had a large (maybe 2 foot square) conductive sheet
(looked like carbon filled rubber) with a grid printed on it. There were sets
of probes for introducing potential "hills" in the sheet and other probes for
measuring the potential at any desired point on the sheet. My memory fails me
here but ISTR that some applications were determining equipotential lines
about odd shapes (using a custom shaped probe) and some kinds of thermal
problems.

> The New Yahoo! Search - Faster. Easier. Bingo.

Peter Wallace

---

From: steve <[email-masked]>
Date: Thu May 1 14:20:01 2003

> For example: Resistive Sheet computers are very

You typically use resistive sheets with op amps no? I
just look at resistive sheets as an accessory of a
analog computer like the EC-1, just like caps,
discrete resistors and wires are accessories.

But can I get a bunch of resistors and a power supply
and call it an analog computer, sure I can, I guess I
should of said "typical commercially available widely
used analog computers"

---

From: "Peter C. Wallace" <[email-masked]>
Date: Thu May 1 14:35:01 2003

> discrete resistors and wires are accessories.

The resistive sheet devices are a whole different class of device and
do not need OP amps at all to do "calculations"

> should of said "typical commercially available widely

Resistive sheet computers were sophisticated commercial devices, not a "bunch
of resistors" I have seen a couple of them so I doubt that they are all that
obscure...

Peter Wallace

---

From: steve <[email-masked]>
Date: Thu May 1 16:11:00 2003

> do not need OP amps at all to do "calculations"

Well yes, resistive sheets devices can be used alone,
but I would call that implementation a calculator,
similar to a slide rule. Resistive sheets were also
commonly used to enhance the computing capabilities of
op amp based analog computers.
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---

From: Peter Turnbull <[email-masked]>
Date: Thu May 1 17:24:00 2003

> op amps they have, and that limits what you can do.

While that's true for most modern *electronic* analog(ue) computers,
it's not a good generalisation.  What about things like Vannevar Bush's
differential analysers, gun directors, Norden bombsights, various
electro-pneumatic or hydraulic computers, or the G-star analog
"computer" used by CalTech at Mt Palomar?

I seem to be in pedant mode today (as Ethan's discovered, possibly) and
I couldn't resist pointing out some alternatives :-)

-- 
Pete						Peter Turnbull
						Network Manager
						University of York

---

From: [email-masked] (Tony Duell)
Date: Thu May 1 19:02:00 2003

> -what is the polarity of the DC-input on the socket? 

According to the schematic in the printed Technical Manual, the connector 
is centre -ve. 

> -Is a filtered 6 volt DC voltage ok or has it to be stabilised?

The mains adapter replaces (electrically) the 4 internal AA cells when
it's connected (there's a switch in the input conenctor that disconnects
the internal battery +ve terminal when you put the adapter plug in). 
Therefore, the adapter doesn't need to be well regulated (since the
batteries aren't). There's a fairly complex DC-DC converter on the main
PCB to produce +5V and -5V from the batteries, and that provides
regulation too. I think the official mains adapter (at least the one sold
in the UK) was just a transformer, rectifier and smoothing capacitor. 

However, I'd not want to apply a voltage wildly different from 6V to the 
machine. It will probably be OK, but I don't fancy rebuilding that DC-DC 
converter if it's not :-)

-tony

---

From: [email-masked]
Date: Thu May 1 21:02:01 2003

In message <[email-masked]>, The Design Fort DTP wri
>my time, but I really would love to learn more about it.

Others have already posted some good information on this.  However,
I thought I'd mention a little thing I wrote up as a handout
for a class on the history of computing I taught several years
ago.  You can find the html version at:

http://bellsouthpwp.net/d/r/drbrians/analog/analog.html

and a PDF file at:

http://bellsouthpwp.net/d/r/drbrians/analog/analog.pdf

It's not an in-depth treatment by any means, but it does give a
run down on the basic math behind how they work.

Brian L. Stuart