Subject: Delay Line Memory(?) ICs

From: Joe <[email-masked]>
Date: Thu Apr 17 20:11:01 2003

I found an odd looking board today that I THINK might be some kind of delay line memory. I'm trying to find out more about the ICs used on it but I'm not finding much. Can anyone id these ICs? MC1662L, MC1043P, MC1010P and MC1040P? They are all 14 pin DIPs expect for the 1662, it is a 16 pin DIP. All of them are dated 1973 to 1976. They are definitely not sync chips or PICS!

   The board itself has seven glass or plastic cylinders about 3 1/2" long and 1/4" in diameter. Each cylinder is wound with a twisted pair of fine wires. Besides the beginning and ending points there are six additional taps in the windings. (A total of 8 connections per wire per cylinder). There are four 1662s next to each cylinder and the white wire of the pair is coupled to them. The red pair of the pair connects to a post that goes through the board. On the back of the the board is a daughter board that is seated on the posts. It has  the 1040s, 1043 and 1010s on it. This board also has a row of four ICs for each cylinder. There are two 1043s and an two 1040s in each row and they apppear to connect to the posts that connect back to the red leads on the cylinders. The four 1010s are mounted on the bottom of the board between the rows of ICs and seem to be pre-drivers or some such. There's also a row of pre-drivers or something like that on the main board. They use MC1668L s and there are seven of them.

   These boards came out of a LARGE test system built by Tektronix. (The same one that I pulled the DEC PDP-11/35 out of.) But someone else pulled these and I'm not sure what unit that came from. The main board and outside panel are marked "2941 Delay" and the daugherboard is marked "Delay Register".

   Any ideas what these boards are?  Can anyone positively id the ICs?

    Joe

---

From: William Donzelli <[email-masked]>
Date: Thu Apr 17 21:20:00 2003

>   I found an odd looking board today that I THINK might be some kind of
> delay line memory. I'm trying to find out more about the ICs used on it
> but I'm not finding much. Can anyone id these ICs? MC1662L, MC1043P,
> MC1010P and MC1040P? They are all 14 pin DIPs expect for the 1662, it is a
> 16 pin DIP. All of them are dated 1973 to 1976. They are definitely not
> sync chips or PICS! 

MECL II and MECL III.

They are all small glue - gates, latches, and I think a 3 to 8 line decoder.

MECL III (the 1600 series) is damn fast - almost as fast as the more
familiar 100K ECL.

William Donzelli
[email-masked]