Subject: KC Computer Swap Shop?

From: Bill Richman <[email-masked]>
Date: Sat Jul 26 19:30:17 2003

Can someone supply an address and/or phone number for the Computer Swap
Shop in Kansas City?  Thanks!

---

From: [email-masked]
Date: Sat Jul 26 23:22:01 2003

> Shop in Kansas City?  Thanks!
It's on Johnson Drive about a mile east of I-635/Metcalf --- north side of
street.
Can't remember the rest.

Gary Hildebrand