Subject: Re: Writing single density disks on a PC?

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon May 19 15:25:00 2003

>From: "Fred Cisin (XenoSoft)" <[email-masked]>
>
>Try Hypercross/PC-Xzap  from Hypersoft.
>I'd like to hear from anybody who has SUCCESSFULLY used 22DISK for

Hi Fred
 I tried 22DISK for my M20 but it didn't work. The tables
were wrong, as well as that my computer didn't deal
with single density. Since it had no way of ignoring
track 0, easily, I gave up on it.
 I found that the single density,
on track zero, was solved by using the M20 to pre-format
the disk and then used my routines to write the double
density stuff to the remaining tracks. If Geoff has the
same issue, he might be able to deal with the single
density the same way. I found that the first track
being single density was just a boot compatability issue.
The first track would just have enough code to switch
to double density and then the main loader was on
track 1. This meant that the code was basically the
same on all of the track zero's.
 I'd forgotten that the BIOS wouldn't deal with the
single density. I was thinking more in terms of number
and size of sectors.
Dwight

>anything other than CP/M, or used ANY commercial product for SD.
>Yes, Catweasel or Option board THEORETICALLY could do it.
>Posters about any product that "can do it", but don't differentiate
>between "CAN DO" and HYPOTHETICAL POSSIBILITY can go F themseves.
>(During the life of my products, I constantly competed with rumored,
>but non-existent, capabilities of some products)

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Mon May 19 21:51:00 2003

> single density. I was thinking more in terms of number

Some chips such as the 37C65 handled single density internally, and if you
spoke directly to the FDC, you could create appropriate commands.  But the
BIOS (13, 1E) were locked in to MFM.  There were a few disk controller
boards for the PC and XT that could do single density, but often they used
mutually incompatible additional ports and commands to switch, naking it
unfeasable to handle them in a commercial product. ("your product
supports Maynard, how come it won't work with my Vista controller, which
is 'just like it'")  For a NON-commercial product, it could be done
without too much hassle.

However, since the goal in THIS case was TRS-80 Model 4, it might be
feasable to use Trakcess on the TRS-80 to do the job.