Subject: RE: possibly OT: Enigma Cypher machine on e-bay.

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon Mar 10 12:50:00 2003

>From: "Hans Franke" <[email-masked]>
>
>> > Hmm...  Doesn't think this is a computer, eh?  Wonder what it *is* then?  
It
>> > calculates, and provides a results of those calculations into some kind of
>> > output -- usually on paper.
>
>> Calling an Enigma a computer is really stretching the definition. They 
>> are incredibly simple machines - the internal circuitry consists of not 
>> much more than a battery, wires, the wheels (fancy rotary switches, 
>> basically), a plugboard, and a bunch of lightbulbs.
>
>Well, as far as it goes, a computer needs to be able to:
>
>a) have a stored (changeable) programm
>b) execute instructions conditionaly
>c) do a loop
>sometimes also cited:
>d) a way for input/output
>
>of these basics, the Enigma is only good for the first one,
>since the wheels can be seen as the programm, and they where
>changeable. None of the other two conditions are met, since
>there is no loop and no conditional operations ... well, ok,
>one may see the repetive execution of the ecryption programm
>as a loop, but then the conditional execution is still missing.

Hi Hans
 I think this one does have the ability to do a loop.
The rotating wheels constitutes a three level loop.
In fact, it is hard wired to loop.
 Lets see:
 
 a. Changing wheels and order changes stored program
 b. Hitting different keys causes conditional change of output
 c. Wheels generate nested loops
 d. Keyboard and display form I/O
 
It looks like it meets your list.
Dwight

---

From: William Donzelli <[email-masked]>
Date: Mon Mar 10 13:04:00 2003

> It looks like it meets your list.

SSSSTTTTRRREEETTTCCCHHH.......

I should point out the the four way switch I use to turn on the lights in 
my kitchen folllow the basic ideas of the Enigma. Do I live in a a computer?

William Donzelli
[email-masked]

---

From: Ron Hudson <[email-masked]>
Date: Tue Mar 11 23:34:00 2003

> my kitchen folllow the basic ideas of the Enigma. Do I live in a a 

Perhaps you only use a computer to control your lights?

: ^ )