Subject: Re: Synertek 6507

From: "Dwight K. Elvey" <[email-masked]>
Date: Thu Mar 13 12:18:01 2003

>From: "Hans Franke" <[email-masked]>
>
>> >According to my 1983 Synertek book, the SY6507 _is_ a 28-pin 65xx CPU with
>> >8K addressing.  The only video controllers they list are the SY6545, SY6845,
>> >SY66450 and SY66550.
>
>> Hi Jim
>>  This is what Eric Smith tells me as well. As I told
>> him, it doesn't make much sense. The board has a 6502
>> as well as the 6507 with the data lines tied together.
>> I guess they could use opposite phases or something.
>> I was tracing down the sync signals for the video
>> and they seem to be coming from this part??
>
>Now it would be interesting where they go. Maybe the
>6507 CPU get's an interupt every line, or screen ?
>
>>  Now I have a mystery to solve?
>
>That's all what classic computing or computing in
>general is about.

Hi Hans
 Both Eric and Jim were right. It is a 6507 uP. I looked
some more at the board and did some tracing. I'll have to
admit, I'd never have thought of it. There is an address
mux going to the code ROM. The clock input are in fact 180
degrees out of phase ( Q and Q\ of a JK-flop ). The sync
signals come from the high order address bits as well.
 The code for making a sync signal is just to do a load
from the higher address. Now, I have to get the code
out of the ROM so I can see exactly how it was done.
It would seem that the 6507 just runs a loop that makes
the needed strobes and the 6502 does the keyboard scan
and RS-232.
 Very clever! It makes one think how simple things could
be today using several PIC chips to do relatively complex
task and replace expensive dedicated chips.
Dwight

---

From: John Honniball <[email-masked]>
Date: Thu Mar 13 14:16:00 2003

Dwight K. Elvey wrote:
> some more at the board and did some tracing.
...
> The clock input are in fact 180
...
>  Very clever!

Isn't that how the Fairlight CMI (Computer Musical Instrument) works?
Only with 6800s instead of 6502/6507?  Does anyone on the list have
a CMI?

--
John Honniball
[email-masked]

---

From: Vintage Computer Festival <[email-masked]>
Date: Thu Mar 13 15:01:00 2003

> Only with 6800s instead of 6502/6507?  Does anyone on the list have

What an AWESOME synth!

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=2514595055&category=38071

But I won't pay $5,600 for one :(

More info:

http://www.ghservices.com/gregh/fairligh/
http://www.vintagesynth.org/misc/fairlight_cmi.shtml
http://www.obsolete.com/120_years/machines/fairlight/

-- 

Sellam Ismail                                        Vintage Computer Festival
------------------------------------------------------------------------------
International Man of Intrigue and Danger                http://www.vintage.org

 * Old computing resources for business and academia at www.VintageTech.com *