Subject: Got Picture? Anyone got a link to a picture of a Televideo 2605?

From: Ron Hudson <[email-masked]>
Date: Tue May 13 23:10:01 2003

Anyone got a link to a picture of a Televideo 2605?

If it's the one I remember... Televideo's PC/AT Color screen
and a box on the side holding 1 10mb  hard drive and 1
5.25 floppy.

Thanks

---

From: "J.C. Wren" <[email-masked]>
Date: Tue May 13 23:45:00 2003

There *may* be one at http://www.machine-room.org/computers/888/, but the 
site appears casters up at the moment.

	--John