Subject: WTD: NEC V20 Hardware Manual, IBM PC schematics

From: "Philip Pemberton" <[email-masked]>
Date: Tue Mar 11 01:10:00 2003

Hi,
    I'm trying to track down a copy of the NEC V20 Hardware Manual. I've
managed to find a PDF version of the Software (programming) Manual, but the
Hardware Manual (which, typically, is filled with the info I need to get
this thing running) is a pain in the neck to find, especially now the V20 is
classified as obsolete by NEC.
    I'm also after a copy of the schematics for the original IBM PC-AT and
PC-XT. Anyone got a set they can scan or photocopy for me?

Thanks.
--
Phil.
[email-masked]
http://www.philpem.dsl.pipex.com/

---

From: Eric Josephson <[email-masked]>
Date: Tue Mar 11 08:11:00 2003

> PC-XT. Anyone got a set they can scan or photocopy for me?

There's a datasheet for the V20 (uPD70108) on partminer.com that
has dc/ac characteristics, timing diagrams, pinouts, etc.  Sorry,
I can't help on the actual hardware manual.  Can you get by with
docs for the 8088?  I thought it was a drop-in replacement.

Where did you find the software manual?

Regards,

--
Eric Josephson

---

From: "Philip Pemberton" <[email-masked]>
Date: Tue Mar 11 11:11:00 2003

Eric Josephson wrote:
> has dc/ac characteristics, timing diagrams, pinouts, etc.
Problem #1: PartMiner seem to have locked access to *ALL* the datasheets.
Fun, fun, fun. What was once a genuinely useful service has now "gone to the
dogs"... Thank-you dot.bomb...

> Sorry,
I might be able to use the 8088 docs. The V20 is *supposed* to be a drop-in
replacement, but IIRC it needed some (minor) BIOS alterations to get it to
work properly in PCs when the 8088 was swapped with a V20.

> Where did you find the software manual?
www.google.com - I searched for "NEC V20 Hardware Manual".

Later.

---

From: "Hans Franke" <[email-masked]>
Date: Tue Mar 11 12:16:00 2003

> classified as obsolete by NEC.

Wasn't the V20 100% Bus (and thus hardware) compatible
to the 8088 ? AFAIK, the difference was just internal
and softwarewise. The 86 core did in any way reassemble
the 86 core of a 186 (same instruction timeing) plus the
added 8080 mode.

Gruss
H.

--
VCF Europa 4.0 am 03./04. Mai 2003 in Muenchen
http://www.vcfe.org/

---

From: "Hans Franke" <[email-masked]>
Date: Tue Mar 11 12:23:01 2003

> work properly in PCs when the 8088 was swapped with a V20.

Not that I know off. The V20 did behave exactly like an 8088.
At some point I did use them on every PC and XT I could. The
additional speed was quite cheap. The only time I couldn't
use a V30 was in the Siemens PC-MX, a small 8086 Unix box.

The self test functions did realy check the timing and result
of all instructions and quite a lot more stuff before jumping
to the boot loader ... so it flagged the V30 as internaly
dammaged...

Beside that one, every machine I erver tried, including original
PCs, second series PC, XTs and various clones did workl flawless
with a V20 (or V30) replacement.

The 'as good as possible' attitude of NEC was in my opinion the
reason for the quite weired switching between 8088 and 8080 mode.
Just to make it as compatible as possible.

Gruss
H.

---

From: "Peter C. Wallace" <[email-masked]>
Date: Tue Mar 11 12:46:00 2003

> the 86 core of a 186 (same instruction timeing) plus the

I remember upgrading an XT clone with a V20 back in those days and it gave a
substantial speed boost (V20 has better hardware/microcode then 8088) There
were no BIOS changes needed, at least on the PC I had.

IICRC there were some compiler changes you could do for code optimization
since the V20 has quite a few added instructions including block I/O

BTW I have the V20 datasheet (in the NEC 16 bit V series 1991 data book)
should someone want to scan it (assuming there is no PDF of it on the web)

Peter Wallace

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Tue Mar 11 13:06:00 2003

> use a V30 was in the Siemens PC-MX, a small 8086 Unix box.

There ARE some differences.  It'll drop in as a replacement on a
5150.  But on a Gavilan, which uses an 8088, there are modifications
required.  Uncle Roger has my old Gavilan files, which include a Gavilan
document detailing the modifications needed.

Besides, it wasn't a completely Bug-For-Bug replacement.  NEC failed to
implement some of the quirks of the 8088.  For example, if an interrupt
occurred during the execution of an instruction with a double prefix, the
NEC would continue, but the intel would drop one of the prefixes when
resuming.  
REP MOVSB DS:[SI] DS:[DI]
will resume with a V20, but with an 8088 will only do one more rep after
an interrupt.

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Tue Mar 11 13:08:00 2003

> since the V20 has quite a few added instructions including block I/O

... and you could do a quick and dirty CP/M emulation if you were willing
to stick to 8080 code

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Tue Mar 11 13:14:00 2003

> PC-XT. Anyone got a set they can scan or photocopy for me?

The IBM Technical Reference Manual(s) included the schematics.  But they
were broken up into a lot of pages.  Dave Thompson ("Microcornucopia"
magazine) took the XT manual and a CAD program, and put the XT ones
together into a single large poster.

---

From: Stan Barr <[email-masked]>
Date: Tue Mar 11 14:18:01 2003

Hi,

> PC-XT. Anyone got a set they can scan or photocopy for me?

I can't help you with either of those, but I have a V20 if you need one.

-- 
Cheers,
Stan Barr  [email-masked]

The future was never like this!

---

From: Eric Josephson <[email-masked]>
Date: Tue Mar 11 14:34:00 2003

> dogs"... Thank-you dot.bomb...

I downloaded it from partminer just last week.  I can understand not
wanting to go through the registration thing, though.  I'll put it up
somewhere if you want a copy.

> www.google.com - I searched for "NEC V20 Hardware Manual".

I thought I tried that, but was probably searching for something
like 70108.  ;-)

By the way, regarding the orignal message:  I do have a copy of the
IBM PC Tech Ref (PC, not XT) with the schematics.  I may be able to
spare some nanocycles to scan them sometime in the next month or so
if nobody else has already done so.

Regards,

--
Eric Josephson

---

From: Ethan Dicks <[email-masked]>
Date: Tue Mar 11 14:38:00 2003

--- "Peter C. Wallace" <[email-masked]> wrote:
> > >     I'm trying to track down a copy of the NEC V20 Hardware Manual...
> >
> > to the 8088 ?
> I remember upgrading an XT clone with a V20 back in those days and it
> gave a substantial speed boost (V20 has better hardware/microcode then
> 8088) There were no BIOS changes needed, at least on the PC I had.

I did the same, but to more efficiently run CP/M programs under an emulator
for MS-DOS.  With better instruction-set compatibility with older
processors, the V20 had to do less emulation and could run more straight
code.

The target application?  Scott Adams adventures for CP/M.  :-)

I still have a V20 and a V30 left over from old C= stock from the local
service center that closed 10 years ago.

-ethan

---

From: "Philip Pemberton" <[email-masked]>
Date: Tue Mar 11 14:52:00 2003

> I can't help you with either of those, but I have a V20 if you need
What package and speed grade?
Better yet, can you tell me what the full part number of the chip and the
asking price is?

Thanks.

---

From: "Philip Pemberton" <[email-masked]>
Date: Tue Mar 11 15:06:01 2003

> somewhere if you want a copy.
I've registered with Partminer, or rather their other site
freetradezone.com. I tried to find a datasheet and it threw up a
"Distributor Access Only" error. A quick request for a CAPS Advisor 14-day
trial sorted that out. Needless to say, I now have full data on 95% of the
ICs in my junk box.

> if nobody else has already done so.
That would be great - thanks. Does the Techref cover the uPD765 floppy disc
controller as well? (did IBM use that chip in the original PC?) Speaking of
disc controllers, I need a few uPD765s. Disc controllers and SuperI/O chips
are like hen's teeth around here. I've got a Holtek HT6552IR in unknown
condition with no data. Holtek did send me the datasheet, but my PC suffered
a hard drive failure (yes, current hard drives are still afflicted by the
age old problem of sticktion).
Someone also mentioned a copy of the IBM PC schematics was included with
Microcornucopia magazine? If this is/was true, I'd love a copy.
A memory map would also be useful. I do have source code for a PC/XT BIOS
(from programmersheaven.com iirc) so I don't need the BIOS sources scanning.
Now I wonder if IBM still have any Techrefs in stock...
And while I'm on the subject of PCs, I've tracked down a really nice Dell
keyboard. It seems like it uses a buckling-spring mechanism. This is based
on the fact that it makes a very loud click when a key goes down. It  also
makes a "boing" type noise akin to a spring popping out and flying into a
wall. It's Dell P/N 093GDJ, FCC ID GYUM90SK.

Thanks.

---

From: "Antonio Carlini" <[email-masked]>
Date: Tue Mar 11 15:12:00 2003

> > Problem #1: PartMiner seem to have locked access to *ALL* the 
> > datasheets. Fun, fun, fun. What was once a genuinely useful service 
> > has now "gone to the dogs"... Thank-you dot.bomb...
> 
> I downloaded it from partminer just last week.  I can 
> understand not wanting to go through the registration thing, 
> though.  I'll put it up somewhere if you want a copy.

A few years ago partminer (aka Free Trade Zone) was available
for free. Then it closed its doors to anyone not paying for
the subscription service (which is $1000s or more per annum).

Now it seems that *some* data sheets are available and some
are locked. Not all discontinued parts are available, I
didn't search long enough to see any logic to it.

I guess as long as *some* stuff is there, it may be worth
registering.

Antonio
 
-- 

---------------
Antonio Carlini             [email-masked]

---

From: [email-masked] (Tony Duell)
Date: Tue Mar 11 17:35:20 2003

> controller as well? (did IBM use that chip in the original PC?) Speaking of

The early editions of the TechRefs included the disk controller card 
schematics. Later on,. these schematics were moved to the Options and 
Adapters TechRef, but were still available. None of the TechRefs AFAIK 
included the 765 (or 8272, much the same chip) data sheet. 

And yes, the original PC disk controller used the 765 chip.

> Now I wonder if IBM still have any Techrefs in stock...

They did some 6 or 7 years ago when I ordered my set...

-tony

---

From: ben franchuk <[email-masked]>
Date: Tue Mar 11 18:45:00 2003

> age old problem of sticktion).

B.G. Micro still has 765's in stock. $4.00 each.
http://www.bgmicro.com/
Ben.

---

From: "Hans Franke" <[email-masked]>
Date: Wed Mar 12 05:23:00 2003

> will resume with a V20, but with an 8088 will only do one more rep after

Well, that's eactly the 186 behaviour. Now considering that the
timeing was also exactly like 186 (or real mode 286), and the
instruction set is the same, I still think NEC just used the
186 (188) core as template for the V20/V30 - Considering that
V40/50 where like the 186 with integrated perhipherals, you
may considere it as a two step knock off...

Gruss
H.

---

From: Mark Tapley <[email-masked]>
Date: Wed Mar 12 09:02:00 2003

>Wasn't the V20 100% Bus (and thus hardware) compatible

I know it was highly compatible, if not completely. The DEC Rainbow could
take a V20 replacement for its 8088. The only other required change was to
the boot PROM, because the V20 completed a loop faster than the 8088 and
would cause trouble (not successfully boot) in the original PROM. The
putatative reason to make the switch was for an (approx., off the top of my
head) 5-10% speedup in execution.

I (think I) can supply details, including the change to the PROM, if anyone
is interested. I have not, however, tried the change myself.

							- Mark

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Wed Mar 12 19:59:21 2003

> Well, that's eactly the 186 behaviour. Now considering that the

Not MY experience.  The 386 is the first Intel that I'm aware of that
fixed the double prefix bug.  But NONE of the NEC v series had that
bug.  (ONE way to tell whether the current chip was Intel or NEC)

> instruction set is the same, I still think NEC just used the

Did the V20 have the INSB/INSW/OUTSB/OUTSW instructions? (present in
80186/80188, but not 8086/8088

> may considere it as a two step knock off...

BUT,...
Other V20 instructions followed the 8088/8086 model.
Such as what happens if you push SP.  For example:

MOV BX, SP
PUSH SP
MOV CX, SP
POP AX
; will copy the value pushed by PUSH SP into AX.
; on the 8088/8086 and the V20, AX will equal CX
; on the 80186/80188, AX will equal BX
(how to tell whether the chip is 8086/8088 v 80186/80188 or above)

NEC fixed some of the bugs, but not all.  Some of them were the basis for
the decision in the Intel v NEC lawsuit.

--
Grumpy Ol' Fred        [email-masked]

---

From: "Peter C. Wallace" <[email-masked]>
Date: Wed Mar 12 22:37:00 2003

> 80186/80188, but not 8086/8088

Yep... We made use of them in the V40 that we used for many years in embedded
Stuff. Plus the V40 has (had?) a really nice DMA controller.

snip...

Peter Wallace

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Wed Mar 12 22:53:00 2003

> Stuff. Plus the V40 has (had?) a really nice DMA controller.

V40.
NOT V20.

If it had the DMA controller then, then it presumably still does :-)

---

From: "Hans Franke" <[email-masked]>
Date: Thu Mar 13 04:28:00 2003

> bug.  (ONE way to tell whether the current chip was Intel or NEC)

I have to step back here. I always thought the 186 had this already
fixed. Maybe I'm mixing up these two CPUs.

Didn't the 80C86/88 also have the double prefix bug fixed ?

> 80186/80188, but not 8086/8088

It had all the 186 extensions, especialy Enter, Leave, Pusha Popa,
Ins, Outs and Imul. I can't gurantee for Bound, 'cause I never used
that on a V20 (but I did on the 186).

Furtermore the V20 did include a bunch of new, nice instructions
(if in 86 mode). Just I know of no software to use them. For example,
A bunch of operations for 4 Bit values - aka BCD and Bitoperations.

> (how to tell whether the chip is 8086/8088 v 80186/80188 or above)

Excuse me ? AFAIR that's the way to check if you had a 286 or
above. the 186 did behave exactly like the 86. the pushed SP
is the decremented value, while 286 and above push the original
value, and the test (at least as I did it) was:
PUSH SP
POP AX
CMP AX,SP
Equal -> 286 or above,
Not Equal -> 186 or below.

To test for 186/88 vs 86/88 (and V20/30) was using the shift
operation. starting with th 186, the shift value was anded 
by 1Fh. So you would load any value except Zero into AX and
load CL with 32, execute a shift. If the resulting AX was
Zero, it was an 86/88 (of V20/30), if not it was a 186 or
above.

Gruss
H.

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Fri Mar 14 14:07:01 2003

I think that your memories of those details are a lot clearer than mine.
It's been a long time, and I never did much of anything with the 186/188,
so never really got the hang of where it fit into the sequence.  I don't
have my files handy, and the few reference materials that are handy
(such as the MASM 5.1 instruction set reference) are unreliable and 
very inconsistent.  Between your knowledge and what it says, I'd be far
more inclined to trust you.

--
Fred Cisin                      [email-masked]
XenoSoft                        http://www.xenosoft.com