Subject: Re: Dragon 64

From: Al Hartman <[email-masked]>
Date: Thu Mar 6 16:32:28 2003

oops!

Guess that was wrong.

I can remember using a Tandy Controller on a Dragon 32
once. But, I guess that one had hacked Coco ROMS.

That might be what I do with this unit, hack a set
Coco ROMS to go into it, just to get it working again.

With a new unit at $35.00, it might not make much
sense to try to get this one working again.

My Coco III is also dead. Green box with no text. I
think the 6809 is bad. At least, that's what I've been
told about these units. So, I'd have to desolder it
and put another one in just to diagnose it.

I may do that some weekend when I feel adventurous.

Suddenly caught the old computer bug....

Al

> From: [email-masked] (tim lindner)
> 
> > I know I can use a Tandy Controller, but I think
> > I'll need a different Disk Basic ROM for it. If
> > anyone can help with that, I'd be obliged...
> 
> Lets see...
> 
> The Tandy controller/software uses the following:
> 
>  Read byte, store byte, halt CPU, un-halt CPU,
> repeat. NMI when done.
> 
> The Dragon controller/software uses the following:
> 
>  SYNC, interrupt, read byte, store byte, repeat. NMI
> when done.
> 
> On the Tandy controller DSKREG is $FF40, and the
> wd179x is mapped
> between $FF48-$FF51.
> 
> On the Dragon controller DSKREG is $FF48, and the
> wd179x is mapped
> between $FF40-$FF43.
> 
> Also the bit patterns for DSKREG are different
> between the Tandy and
> Dragon controllers:
> 
>  *
>
---------------------------------------------------------------
>  * DSKREG - the control register
>  * CoCo ($ff40)                        Dragon
> ($ff48)
>  *
>  * Bit                                 Bit
>  *  7 halt enable flag                  7 not used
>  *  6 drive select #3                   6 not used
>  *  5 density (0=single, 1=double)      5 NMI enable
> flag
>  *    and NMI enable flag
>  *  4 write precompensation             4 write
> precompensation
>  *  3 drive motor activation            3 single
> density enable
>  *  2 drive select #2                   2 drive
> motor activation
>  *  1 drive select #1                   1 drive
> select high bit
>  *  0 drive select #0                   0 drive
> select low bit
> 
> 
> It would take some serious hacking to transform a
> CoCo FDC into a Dragon
> FDC.
> 
> -- 
> The ears are too length.
>
--------------------------------------------------------
> tim lindner                   
> [email-masked]

---

From: [email-masked] (Tony Duell)
Date: Thu Mar 6 18:18:01 2003

> and put another one in just to diagnose it.

I have a CoCo 3 service manual here, if you want me to look anything up 
(like the schematics...)

Before assuming the 6809 is dead, I'd want to do some tests. Is there any 
bus activity,, for example. Is the RAM being accessed/refreshed? Is the 
ROM ever being enabled? And so on...

-tony