Subject: IC 74F582

From: Jim Donoghue <[email-masked]>
Date: Wed Mar 19 09:30:00 2003

Does anyone know what this is? It's on a board with six 74LS181's and
two 74F582, as well as some static RAM and a ton of other TTL logic.

-- 
Jim Donoghue
Smithy Co.
(734) 913-6700

---

From: [email-masked] (Tony Duell)
Date: Wed Mar 19 17:37:00 2003

> two 74F582, as well as some static RAM and a ton of other TTL logic.

According to the Philips FAST databook, it's a 4 bit BCD ALU.

Pinout : 
1 : B2 
2 : A/,S
3 : B3
4 : A3
5 : C,B/
6 : G/
7 : P/
8 : C.B/_n+4
9 : N/C
10 : A=B
11 : N/C
12 : Gnd
13 : F2
14 : F3
15 : N/C
16 : F1
17 : F0
18 : B0
19 : A0
20 : A1
21 : A2
22 : B1
23 : N/C
24 : Vcc

Where : 
An = one operand input
Bn = other operand input
Fn = function output
A/,S = Add (low), Subtract (high) input
C,B/ = Carry, Borrow input
C,B/_n+4 = Carry, Borrow output
P/ = Carry Propagate output
G/ = Carry Generate Output
A=B = comparator output (open collector)

-tony