Subject: Vax 6000-430 upgrade to 6000-620

From: "Geoff Roberts" <[email-masked]>
Date: Tue May 6 22:18:00 2003

Following a successful trans-Pacific trade, (for a DRQ3B) I have the following that will (theoretically) upgrade my Vax 6000-430 to
a 6000-620.

2 T2054-AA 6000-600 CPUs
1 T2019 3.3V regulator, 25A

Can Antonio or one of the other DEC experts confirm that there are no other hardware mods required to the Vax 6000-200/300/400
series cabinets (this particular machine was originally a 6000-310 IIRC) to support the 500 & 600 series cpu boards other than the
insertion of the T2019 3.3v regulator board?  ie no re-cabling etc?
AFAIK this is a plug it in and go field upgrade but would like to confirm it before committing irreplaceable hardware to possible
destruction.
Can't seem to find much on the web about the process itself.

Thanks.

Geoff in Oz

---

From: Huw Davies <[email-masked]>
Date: Tue May 6 22:44:00 2003

At 12:46 PM 7/05/2003 +0930, Geoff Roberts wrote:
>Following a successful trans-Pacific trade, (for a DRQ3B) I have the 
>following that will (theoretically) upgrade my Vax 6000-430 to
>a 6000-620.
>
>2 T2054-AA 6000-600 CPUs
>Can Antonio or one of the other DEC experts confirm that there are no 
>other hardware mods required to the Vax 6000-200/300/400
>series cabinets (this particular machine was originally a 6000-310 IIRC) 
>to support the 500 & 600 series cpu boards other than the
>AFAIK this is a plug it in and go field upgrade but would like to confirm 
>it before committing irreplaceable hardware to possible
>destruction.

It's been a while since I worked on 6000 series VAXen (it's about 4 years 
since I left La Trobe Uni). My immediate recollection is that the upgrade 
requires new CPUs and new memory as well - although it might be that the 
memory I had was too small/old to work in the 6000-300 that became a 
6000-500. I do recall it was just a matter of pulling the old stuff out and 
adding the new stuff in.

Huw Davies           | e-mail: [email-masked]
Melbourne            | "If soccer was meant to be played in the
Australia            | air, the sky would be painted green"

---

From: "Geoff Roberts" <[email-masked]>
Date: Tue May 6 22:52:01 2003

----- Original Message -----
From: "Huw Davies" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, May 07, 2003 1:12 PM
Subject: Re: Vax 6000-430 upgrade to 6000-620

<snip>

> requires new CPUs and new memory as well

I have some ram that is suitable if the installed stuff isn't I think.

> although it might be that the memory I had was too small/old to work in the 6000-300 that became a

Ok, that was the bit I needed to know.  I was fairly sure it was just that, but wanted to be certain I wasn't going to blow anything
up.
If the RAM can't handle the pace I can solve that.  I was just concerned about the CPU's and the regulator..

Thanks Huw.

Cheers

Geoff

---

From: "Antonio Carlini" <[email-masked]>
Date: Wed May 7 15:30:01 2003

> > although it might be that the memory I had was too 
> small/old to work 
> > in the 6000-300 that became a 6000-500. I do recall it was just a 
> > matter of pulling the old stuff out and adding the new stuff in.
> 
> Ok, that was the bit I needed to know.  I was fairly sure it 
> was just that, but wanted to be certain I wasn't going to 
> blow anything up. If the RAM can't handle the pace I can 
> solve that.  I was just concerned about the CPU's and the regulator..

I've missed the beginning of this thread, but if I got
the gist of it right, my recollection (albeit 
fuzzy now) is that the -500 and -600 need the
later memory and won't work with the older memory.

To be sure, pick up the relevant manuals, which you
can probably find by searching here:
       http://vt100.net/manx/

Antonio

-- 

---------------
Antonio Carlini             [email-masked]

---

From: "Antonio Carlini" <[email-masked]>
Date: Wed May 7 15:46:00 2003

> Can Antonio or one of the other DEC experts confirm that 
> there are no other hardware mods required to the Vax 
> 6000-200/300/400 series cabinets (this particular machine was 
> originally a 6000-310 IIRC) to support the 500 & 600 series 
> cpu boards other than the insertion of the T2019 3.3v 
> regulator board?  ie no re-cabling etc? AFAIK this is a plug 
> it in and go field upgrade but would like to confirm it 
> before committing irreplaceable hardware to possible 
> destruction. Can't seem to find much on the web about the 
> process itself.

The specific manual you want is:

EK-650EB-UP-002 VAX 6000 XMI Conversion Manual

which is online according to  http://vt100.net/manx

If that turns out to be wrong (i.e. not online) let me
know and I'll dig out my copy and send it along. I
can provide pointers to the unclear bits, but you'll
definitely want the manual - it will speed things
up immensely.

There are (at least) two ways of converting from
pre-6500 to 6500/6600. One involves the full
upgrade that swaps PSU blocks and so on. The 
other (which seems to be what you have) is
to add a T2019 to provide an additional voltage
on previously unused XMI connections. This latter
route does not (AFAICR) involve replacing
the backplane.

The manual lists which options don't mind the
extra voltage and which probably would prefer
to live in a different cabinet - you're safer
reading the details in the manual than relying
on my memory at this point!

I think that you just add the T2019, swap in
KA66A and MS65A, remove the modules that won't
work in the new config (nothing significant
IIRC, probably the older style CPUs) and
off you go.

There may be a restriction on the number of
I/O modules you can use if you have a T2019
and obviously you lose an XMI slot!

The KA66 supports large amounts of physical
memory, possibly up to 3.5GB. If you choose
to do this, something else needs to be changed
to work properly (just SW, no HW smokes IIRC).
It's probably the XMI-BI adapter that needs to
be upgraded to the + version. If you don't do
this, the OS refuses to use the extra memory.

I'm reasonably sure the KA65 could also do this
(although for smaller amounts of memory, probably
1GB). I'm reasonably sure that this was never
supported in the field. If you happen to have one,
the VAX 9000 was also capable of going beyond
512MB, but again it may never have been supported
(in fact, the entire system should probably never
have been built :-)).

Antonio

-- 

---------------

---

From: "Geoff Roberts" <[email-masked]>
Date: Wed May 7 19:20:01 2003

----- Original Message ----- 
From: "Antonio Carlini" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 08, 2003 6:14 AM
Subject: RE: Vax 6000-430 upgrade to 6000-620

> which is online according to  http://vt100.net/manx

Thank you sir.  I have the manual.  I'll look into the details now.
As usual, CC to the rescue.

Cheers

Geoff in Oz

---

From: "Geoff Roberts" <[email-masked]>
Date: Wed May 7 20:09:00 2003

----- Original Message -----
From: "Antonio Carlini" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, May 08, 2003 6:14 AM
Subject: RE: Vax 6000-430 upgrade to 6000-620

> which is online according to  http://vt100.net/manx

Further:

That manual gives the full upgrade procedure to install an XMI-2 card cage, which includes changing
regulators and card cages etc etc.  It points to a simpler process in manual EK-650EB-UP-002 Vax 6000: Installing Model 500
Processors.

This is the upgrade that uses the T2019.  It's also online.  There are some limitations.  Not more than 12 XMI cards and not more
than 4 cpus.
Some other cards won't work in this configuration and require the full backplane and psu upgrade.

Unfortunately, it's also revealed that there is a bus bar cable that connects the 5V rail to the T2019 and supplies the 3.3v
generated by it to the bus. I don't have this.  However it also mentions that some 300 & 400 series machines have 3.3v capability
and only require the removal of a 3.3v inhibit cable.  I will investigate and see whether any of my 6000 chassis are configured this
way, if so, I may have a work around as this removes the need to install the T2019 regulator board.  There are some compatiblility
issues with memory and some other cards.  MS62 RAM will not work, it requires MS65 or better.  I have a mixed bag of memory modules
so I can probably sort something out.  There is also mention of a firmware upgrade, but I'll cross that bridge when I get to it.

Thanks for your help.

Cheers

Geoff in Oz

---

From: [email-masked]
Date: Sun May 11 20:04:27 2003

> can probably find by searching here:

And wasn't there a backplane revision change between the -200 and -400
somewhere?

Peace...  Sridhar