Subject: 6850 IC needed

From: [email-masked]
Date: Sun Apr 20 17:09:00 2003

I have an old floppy disk drive interface with a dead MC6850P IC in it.

Anyone know of a source for these?  MCM, Jameco, and Digikey don't list
them anymore :-(

TIA --

Glen
0/0

---

From: Paul Berger <[email-masked]>
Date: Sun Apr 20 18:37:00 2003

You fixing an OSI system?

Paul

---

From: Ethan Dicks <[email-masked]>
Date: Sun Apr 20 19:50:00 2003

> Anyone know of a source for these?  MCM, Jameco, and Digikey don't list

B.G. Micro - $1.75

http://www.bgmicro.com/prodinfo.asp?sid=08246180555555562416016975&prodid=ICS6850&page=1&cri=6850&stype=3

I've seen these in use with Commdore peripherals like the D9060/D9090
hard drives.  What are you restoring?

-ethan
The New Yahoo! Search - Faster. Easier. Bingo
http://search.yahoo.com

---

From: John Boffemmyer IV <[email-masked]>
Date: Mon Apr 21 01:11:34 2003

Glen: try Newark Electronics or Allied Electronics. Both are very 
comprehensive, much more so than Jameco.
-John

>Anyone know of a source for these?  MCM, Jameco, and Digikey don't list

----------------------------------------
Founder, Lead Writer, Tech Analyst
and Web Designer Boff-Net Technologies
http://boff-net.dhs.org/index.html
---------------------------------------