Subject: Ignoring Mount requests on startup in OpenVMS

From: "James W. Brinkerhoff" <[email-masked]>
Date: Sun Mar 30 20:44:00 2003

I have a VAX running VMS 7.1  that is looking for a volume thats not actually in existence anymore.   It does this during startup and doesn't give up...    Being a VMS newbie and all, how would I tell the system to ignore this and continue /w the boot?

for example....

%%%%%%%%%%%  OPCOM  30-MAR-2003 21:28:59.95  %%%%%%%%%%%
Request 1, from user SYSTEM on ODIF01
Please mount volume USER2 in device _$1$DKB100: (ODIF01)

-jwb

-- 
## James W. Brinkerhoff <[email-masked]>
##
## GPG Key Sig: EBF1 6C24 0814 A3E9 6E93  649C 1F25 D807 E484 C9B9

[demime 1.01a removed an attachment of type application/pgp-signature]

---

From: "Zane H. Healy" <[email-masked]>
Date: Sun Mar 30 21:16:00 2003

>I have a VAX running VMS 7.1  that is looking for a volume thats not
>actually in existence anymore.   It does this during startup and doesn't
>give up...    Being a VMS newbie and all, how would I tell the system to
>ignore this and continue /w the boot?
>
>for example....
>

Try the following to figure out what startup file is trying to mount the disk:

$ SEARCH *.COM USER2

I'm guessing it's located in SYSTARTUP_VMS.COM, you can simply edit the
file by doing a:

$ EDIT SYSTARTUP_VMS.COM and either remove the line totally or comment it
out by putting a '!' after the '$' on that line.  When done with your edit
do a CTRL-Z to save and exit (assuming you're using the default editor).,

			Zane
--
| Zane H. Healy                    | UNIX Systems Administrator |
| [email-masked] (primary)    | OpenVMS Enthusiast         |
|                                  | Classic Computer Collector |
+----------------------------------+----------------------------+
|     Empire of the Petal Throne and Traveller Role Playing,    |
|          PDP-10 Emulation and Zane's Computer Museum.         |
|                http://www.aracnet.com/~healyzh/               |

---

From: Patrick Finnegan <[email-masked]>
Date: Sun Mar 30 21:27:00 2003

> do a CTRL-Z to save and exit (assuming you're using the default editor).,

I don't think he's going to be able to edit the file if he can't get the
machine to boot up because it's waiting for the op to mount the volume.
I'm guessing he needs to know how to get the machine to boot without
executing the script that's trying to mount that.

My suggestion would be to search google for how to recover a lost root
password in VMS, that'll probably point you in the direction you need to
look to get a DCL prompt without executing startup scripts.

Pat
--
Purdue Universtiy ITAP/RCS
Information Technology at Purdue
Research Computing and Storage
http://www-rcd.cc.purdue.edu

---

From: "James W. Brinkerhoff" <[email-masked]>
Date: Sun Mar 30 21:37:00 2003

On Sun, 30 Mar 2003 22:30:48 -0500 (EST)
Patrick Finnegan <[email-masked]> wrote:

# > Try the following to figure out what startup file is trying to mount the disk:
# >
# > $ SEARCH *.COM USER2
# >
# > I'm guessing it's located in SYSTARTUP_VMS.COM, you can simply edit the
# > file by doing a:
# >
# > $ EDIT SYSTARTUP_VMS.COM and either remove the line totally or comment it
# > out by putting a '!' after the '$' on that line.  When done with your edit
# > do a CTRL-Z to save and exit (assuming you're using the default editor).,
# 
# I don't think he's going to be able to edit the file if he can't get the
# machine to boot up because it's waiting for the op to mount the volume.
# I'm guessing he needs to know how to get the machine to boot without
# executing the script that's trying to mount that.
# 
# My suggestion would be to search google for how to recover a lost root
# password in VMS, that'll probably point you in the direction you need to
# look to get a DCL prompt without executing startup scripts.

Doh!  I actually performed that procedure when I first got my hands on the VAX a while back.   The memory is not what it used to be ;)  

thanks

-jwb

---

From: "Zane H. Healy" <[email-masked]>
Date: Sun Mar 30 21:55:00 2003

>Doh!  I actually performed that procedure when I first got my hands on
>the VAX a while back.   The memory is not what it used to be ;)

Yours isn't the only one!  For some reason I didn't think about the fact
you'd not be able to get to a prompt.

			Zane

---

From: "Antonio Carlini" <[email-masked]>
Date: Mon Mar 31 11:15:00 2003

> Yours isn't the only one!  For some reason I didn't think 
> about the fact you'd not be able to get to a prompt.

The OpenVMS FAQ lives at
http://h71000.www7.hp.com/wizard/openvms_faq.html

The slightly quicker way than the one they recommend is:

	>>> B/1
	SYSGEN> SET UAFALTERNATE 0
	SYSGEN> SET STARTUP_P1 "MIN"
	SYSGEN> SET WRITES 0
 	SYSGEN> CONTINUE
	... wait for boot to complete
	... log in on console as SYSTEM with any passwords
	... edit as required
	... reboot to check

In the future, replacing MOUNT with MOUNT/NOASSIST should
get around the problem in case any other disks mysteriously
vanish (unless the boot disk goes south, of course).

Antonio
 
-- 

---------------
Antonio Carlini             [email-masked]