Subject: General Automation SPC-16/4x & HP PTP

From: Patrick Finnegan <[email-masked]>
Date: Thu Jun 26 15:54:01 2003

I managed to pick up a General Automation SPC-16/40 and SPC-16/45.
Aparently, the /40 needs its power supply to be repaired :(.

Does anyone have info on these things?  Searching google doesn't yeild a
whole lot.  They've got fairly nice frontpanels, and seem to be 16 bit
machines (and have some _real_ core ;-).  I got a disk pack drive to go
with one (Single platter 14" cartridge, a lot like a DEC RL01), but not
too much else.

I'd like to get at least one of them 'set up' to play with.

Oh yeah, if anyone's interested in one, make me an offer.  I *might* be
willing to let one go if the price is right.

I also picked up an HP paper tape punch that seems to be in less-than-
working condition,  I haven't even checked the fuse yet, so we'll see if I
can get it working.   They were even nice enough to leave 1/2 a roll of
blank tape on it.

Now all I need is a paper tape reader and card punch/reader...

Pat
--
Purdue University ITAP/RCS
Information Technology at Purdue
Research Computing and Storage
http://www.itap.purdue.edu/rcs/

---

From: David Comley <[email-masked]>
Date: Mon Jun 30 08:50:00 2003

> Aparently, the /40 needs its power supply to be
Lucky you - I have been looking for an SPC-16 for some
time now. And there's precious little information on
the web. These were popular in Europe in the
industrial arena.

You may know all this already, but here's the little
bit I remember from using these systems. IIRC they are
16-bit systems; the systems I used ran RTOS booted
from 5- or 10-meg removable disk cartridges. At some
point I believe Tripos was also available. We used
these systems extensively at Ford Motor Company plants
across Europe as the controllers for engine
(dynamometer) testing, vehicle exhaust emission
analysis and electrical checkout. In fact I first came
to grips with assembly language programming on the
SPC-16. Back in the '70's someone at Ford wrote a
real-time executive for these systems called the Ford
Executive and Control Program which was only used at
run-time to support the test applications I was
writing, so development was interesting: I'd boot from
RTOS, edit and assemble my code; transfer to a
bootable 8" disk containing FECP; then reboot from the
diskette and attempt to test. Last time I used these
systems was in the late '80s, and at that time General
Automation was still in business. I don't think
they're around now.

Sorry that I don't have much more concrete information
on the hardware to share with - looking back over what
I wrote it's only personal experience stuff - but
sometimes a little context is useful on these systems.
I came across a reference to these machines in the
Technical Library at work recently, comparing them
performance-wise to other minis of the same era. If
you're interested I'll copy the relevant pages and
send them to you.

Regards,
Dave