Subject: What is this? eBay #3409766995

From: [email-masked]
Date: Fri Mar 28 11:35:00 2003

Described as "One of the first portable computers ever made," hex keypad,
the word "Eclipse" on side of unit, fits in a briefcase, seller claims it
was made for Lawrence Livermore Labs.

Any ideas?

Glen
0/0

---

From: Robert Borsuk <[email-masked]>
Date: Fri Mar 28 12:05:00 2003

Is it an MST-80b?

> was made for Lawrence Livermore Labs.
Robert Borsuk - [email-masked]
President
Colourfull Creations
http://www.colourfull.com