Subject: PCjr 1.44 floppy controller

From: Brian Heise <[email-masked]>
Date: Mon Mar 3 22:36:56 2003

I am curious if anyone ever had one of the Legacy Enhanced Floppy Controllers for the PCjr, was ever able to duplicate one, or know if it was ever possible to modify the current controller to take on a 1.44mb capacity.  

I have a Racore unit with a modified 3.5" 1.44mb drive that acts as 720kb, and is fantastic, but would love that extra storage space if available!

Brian

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Mon Mar 3 22:37:25 2003

On Mon, 3 Mar 2003, Brian Heise wrote:
> I am curious if anyone ever had one of the Legacy Enhanced Floppy
> Controllers for the PCjr, was ever able to duplicate one, or know if

"have?"  no
"ever had"  yes
I sold my Jr's a few years ago.  But the guy who bought the one with the
"Legacy" board brought it back to sell it at VCF last year.

> it was ever possible to modify the current controller to take on a
> 1.44mb capacity.
> I have a Racore unit with a modified 3.5" 1.44mb drive that acts as
> 720kb, and is fantastic, but would love that extra storage space if
> available!

720K does not require any modification.  See also, the PC-JX (never sold
in USA)
Using a 1.4M drive for 720K usually doesn't require any mods.

But getting 1.4M to work on a JR poses some problems.
The STOCK controller for the Jr. would need a minor hardware mod to get
the 500K bits per second data transfer rate.
And the stock controller does NOT do DMA.  Can you write the code tight
enough to do the data transfer through the CPU at "high density" rates?

--
Fred Cisin                      [email-masked]
XenoSoft                        http://www.xenosoft.com

---

From: Brian Heise <[email-masked]>
Date: Mon Mar 3 22:37:42 2003

Fred
Thanks for the info.  Actually, I did do a modification to mine.  I guess I should clarify my 3.5" floppy mod.  I just hacked the Drive Select, so I could use the standard Racore floppy drive cable.  I didnt want, or have the means, as I do now, to make my own cables.  
Wish I had one of those controllers!
Brian

"have?" no
"ever had" yes

---

From: Brian Heise <[email-masked]>
Date: Mon Mar 3 22:38:31 2003

I am looking for PCjr cartridges, mainly ones from PC Enterprises, like the Combo Cartrisge, Keyboard Buffer Cartridge, Quicksilver and JrVideo.  Of course all PCjr specific software and cartridges are welcomed in my home! 
Also on the lookout for sidecars (Really want a TMC 850jr SCSI sidecar - also from PC Enterprises), serial cards fitted for the modem slot, memory sidecars, MS sidecars, AST PCNetIIjr's,  Legacy Expansion units, HDD kits of anykind (I think Racore made one as well).
I would be willing to trade or buy outright if you wish.  Let me know what you have!
Thanks!!
 
Brian

---

From: "Andrew Strouse" <[email-masked]>
Date: Thu Mar 6 22:19:15 2003

I have a joystick new in box.  If you're interested.

----- Original Message -----
From: "Brian Heise" <[email-masked]>
To: <[email-masked]>
Sent: Monday, March 03, 2003 9:45 PM
Subject: WTB: PCjr Items

> I am looking for PCjr cartridges, mainly ones from PC Enterprises, like
the Combo Cartrisge, Keyboard Buffer Cartridge, Quicksilver and JrVideo.  Of
course all PCjr specific software and cartridges are welcomed in my home!
> Also on the lookout for sidecars (Really want a TMC 850jr SCSI sidecar -
also from PC Enterprises), serial cards fitted for the modem slot, memory
sidecars, MS sidecars, AST PCNetIIjr's,  Legacy Expansion units, HDD kits of
anykind (I think Racore made one as well).

---

From: Brian Heise <[email-masked]>
Date: Thu Mar 6 22:20:33 2003

Andrew
Well, if you are planning on just getting rid of it, I would take it off your hands, but as of right now, I have about 20 of them sitting in a back room :)  they could always use another friend! :)
Brian
 Andrew Strouse <[email-masked]> wrote:I have a joystick new in box. If you're interested.