Subject: ROM on Altair front panel board

From: "Cini, Richard" <[email-masked]>
Date: Wed Jul 30 21:45:37 2003

Hello, all:

	I was just looking at the schematics for the display/control board
for the Altair 8800 and saw that there is a 1702 EPROM on the board. The
lowest 4-bits of the EPROM's address bus are connected to a 7493 binary
counter and the highest 4-bits are connected directly to the address bus.

	What's the purpose of the EPROM? Did the front panel have some
intelligence?

Rich

---

From: "Kapteyn, Rob" <[email-masked]>
Date: Wed Jul 30 22:09:00 2003

Which version Altair ?
The original Altair has no ROM anywhere.

I think you are looking at the "turn-key" version.
It has no switches for manual intervention, so it would have to have some intelligence,
in the form of a boot-loader.

I have never worked with a turn-key version, so I am not sure.

-Rob

-----Original Message-----
From: Cini, Richard [mailto:[email-masked]]
Sent: Monday, July 28, 2003 12:15 PM
To: CCTech (E-mail)
Subject: ROM on Altair front panel board

Hello, all:

Rich

---

From: "Cini, Richard" <[email-masked]>
Date: Wed Jul 30 22:12:13 2003

Bob:

	I don't know the exact Altair model the schematics relate to, but
it's not the turnkey model. The ROM socket appears on the display/control
board schematic, which has the front panel switches and LEDs. The Altair
Turnkey would, I believe, have a different board in it called the Turnkey
Module or something like that.

	If you want to see the schematic, go to my Altair32 Emulator page
and look on the technical links page for the ZIP file containing scans of
the schematics. I do not have an Altair, and I got these schematics from
another source. The only designation on the page is "Figure 3-16;
Display/Control Schematic (sheet 1 of 3)".

	The URL is
http://highgate.comm.sfu.ca/~rcini/classiccmp/Altair32.htm

	I've had these schematics for a while, but I never looked at them
that closely.

Rich
-----Original Message-----
From: Kapteyn, Rob [mailto:[email-masked]]
Sent: Monday, July 28, 2003 2:37 PM
To: [email-masked]
Subject: RE: ROM on Altair front panel board

Which version Altair ?

I think you are looking at the "turn-key" version.
It has no switches for manual intervention, so it would have to have some
intelligence,
in the form of a boot-loader.

-Rob

-----Original Message-----
From: Cini, Richard [mailto:[email-masked]]
Sent: Monday, July 28, 2003 12:15 PM
To: CCTech (E-mail)
Subject: ROM on Altair front panel board

Hello, all:

Rich

---

From: "Erik Klein" <[email-masked]>
Date: Wed Jul 30 22:18:39 2003

> 	What's the purpose of the EPROM? Did the front panel have some

I'm pretty sure that you're looking at an Altair 8800B front panel 
schematic.  I believe those were software controlled front panels.  The 
8800 and 8800a had no EPROMs on the front panel - just TTL and the 
switches, LEDs, etc.

   Erik Klein
   www.vintage-computer.com/vcforum
   The Vintage Computer Forum