Subject: HP's Amigo Protocol, HFS

From: "Peter Brown" <[email-masked]>
Date: Sat May 3 12:58:38 2003

Hi Joe,

The drive is a 9134XV - serial number begins with 23 so I guess that it 
would be from around 1983.  If I look at the drive with an HP 9000 332 it 
sees an HFS partition - with basic 6.0 binaries :).

When I ask the drive to identify itself it returns a pair of bytes that I 
don't recognise (1 and 15 from memory but I could be wrong).  This pair of 
bytes is not the same as the pair that would be returned by a CS80 drive.

I managed to check the reader software with a pair of 9133 drives, a 9134 
drive (which fails) and a 7907 drive (this identifies itself correctly but 
appears to have been wiped of data at some time).

I have some other software recorded on 7906 removable cartridges - does 
anyone know if an HPIB version of this drive was made? - I think that the 
model number may be 7906H but I have no further information.  Does anyone 
have a 7906H tht they don't need?

Cheers

Peter Brown

_________________________________________________________________
On the move? Get Hotmail on your mobile phone http://www.msn.co.uk/mobile

---

From: Joe <[email-masked]>
Date: Sun May 4 01:30:49 2003

At 05:53 PM 5/3/03 +0000, you wrote:
>The drive is a 9134XV - 

  It's definitely an Amigo drive then.

serial number begins with 23 so I guess that it 
>would be from around 1983. 

   Correct.

 If I look at the drive with an HP 9000 332 it 
>sees an HFS partition - with basic 6.0 binaries :).

   My initial thought was the Amigo wouldn't suppport HFS but after some thought I don't see any reason that it wouldn't. 

>bytes is not the same as the pair that would be returned by a CS80 drive.

    I don't know much about the internals of the drives so I don't know what those might mean. I looked at the docs that I have on the 9133XV and I don't see anything with those numbers. Check them and let me know if that's the right numbers. If it's not, tell me the correct numbers and I'll see if they match anything in the specs.

>drive (which fails)

   That's odd. Is the drive bad? Most systems identify a 9134 as a 9133 with no floppy drive.

    What kind of HP system are you checking these on and what BootROM does it have? Does the HP system show the 9134? What letter model is the 9134?

 and a 7907 drive (this identifies itself correctly but 
>have a 7906H tht they don't need?

   I'm not sure of the model numbers but it appears that HP made both HP-IB and MAC versions of the 7906.  I believe that they used an adapter (pn 12745C/D) to convert from MAC to HP-IB interface. The two models that I have listed in my HP 9000 Configurator manual are 7906M and 7906MR. The docs also list 7906C/D and I THINK those are M/MR models with Option 102 installed. No idea what option 102 is. Reading further I found, "There is no HP 9000 interface for the 13037 controller <I>without</I> an HP-IB adapter. The 7906H/HR ICD disks sare known <I>not</I> to work. The usability of the 7906S(slave) 7906A/B  and 7905A disk is not known." Italics <I> are HPs. I hope that confuses you as much as it did me!   BTW the 13037 is some kind of MAC interface. I had one but gave it to Eric.

   BTW HP says that these drives are not supported under BASIC, HP-UX or Pascal! (at least at that time) It also says that no support is planned for any HP 9000 system.  Also they state that these drives are obselete and recommend that people use the newer and more economical 7907A drives. I looked under the 7907 description to see if it would read the 7906 media but it doesn't say. However the 7907 tape media was 20.5 Mb vs 9.8Mb so it is different. The 7908 drive is described as 16.6 Mb fixed disk and a "1/4 inch "88140" shared controller tape drive". Most (all?) of the newer drives that incorporate tape drives are also described as 88180 tape drives so the drive and media used in the earlier 7906 and 7907 are different from the later stuff.

   Joe