Subject: VAX DSSI dyssentary?

From: "John Allain" <[email-masked]>
Date: Fri Jun 20 17:26:59 2003

I have a 'new' microVAX 4000-200 here that has a few small oddities 
with it, and I could use some advice.  Number one is that it will not boot.
I tried 'b dia0' and 'b/r5:e0000001 dia0' and both times it's nothing until
timeout.  Number two is that 'show dssi' and 'sho dev' show no disks, nor
the TF85.  After some initial confusion where one or more disks were 
tried uncabled before powerup, the DSSI terminator was discovered
missing, so I used one from another machine.

My questions are, are there other tests for a disk besides booting it, 
and, what could be wrong with the DSSI bus?
I tried other DSSI ID's on the disks but no real change.
Do the ID's have to start with 0?

A tidbit with the terminator off was that the countdown tests went from
95.. to 60.. and then autobooted immediately back to 95 without continuing
down.  I could have sworn at the time that 'sho dssi' worked then.
Probably unreleted but FYI.

TIA
John A.

---

From: Paul Thompson <[email-masked]>
Date: Fri Jun 20 17:30:07 2003

Once you are able to see the disks you should be able to SET HOST/DUP to 
them  from the console but you're obviously not there yet.

Have you tried hooking the devices one at a time and doing a SHOW DEVICE?
I take it the red 'fault' light is not coming on on the drives?

Does your host even show up in the SHOW DEVICE?

     DSSI Node 6 (*)      
- or -
     DSSI Node 7 (*)      

Perhaps the full output of SHOW DEVICE might be helpful.

--

---

From: "John Allain" <[email-masked]>
Date: Sat Jun 21 18:12:51 2003

> I take it the red 'fault' light is not coming on on the drives?

Just once, but it cleared.

Here's the boot seq. I was talking about:

"KA660-A V4.9, VMB 2.12
 Performing normal system tests.
 95..94..93..92..91..90..89..88..87..86..85..84..83..82..81..80..
 79..78..77..76..75..74..73..72..71..70..69..68..67..66..65..64..
 63..62..61..60.."
(stops and loops back to the beginning for ~3 minutes... then:)
"KA660-A V4.9, VMB 2.12
 Performing normal system tests.
 95..94..93..92..91..90..89..88..87..86..85..84..83..82..81..80..
 79..78..77..76..75..74..73..72..71..70..69..68..67..66..65..64..
 63..62..61..60..59..58..57..56..55..54..53..52..51..50..49..48..
 47..46..45..44..43..42..41..40..39..38..37..36..35..34..33..32..
 31..30..29..28..27..26..25..24..23..22..21..20..19..18..17..16..
 15..14..13..12..11..10..09..08..07..06..05..04..03..
 Tests completed."
(came up to temperature...perhaps?)

Wonder what test 59 is and what a failure there signified?

> Does your host even show up in the SHOW DEVICE?
Yes, like that.
> Perhaps the full output of SHOW DEVICE might be helpful.
Here:

">>>sho dev
 DSSI Bus 0 Node 7 (*)

 UQSSP Tape Controller 0 (774500)
 -?

 Ethernet Adapter
 -EZA0 (08-mac..mac-F7)"

The "-?" looks wierd.
sho dssi, again, showed no tape.  nothin' but controller.

thx for responding.
John A.

---

From: Paul Thompson <[email-masked]>
Date: Sun Jun 22 19:26:53 2003

That -? does look odd.  Could the UQSSP have been added in later?
You have nothing hooked to it if your only tape is a TF series drive, 
true?

I don't know what to make of the self tests.  Perhaps someone configured a 
script of tests.  There is supposed to be a way to do that.

What does T 9E show?  On other/older machine this lists the selftests.

Sorry for top posting
Paul

--

---

From: "John Allain" <[email-masked]>
Date: Sun Jun 22 19:28:16 2003

> You have nothing hooked to it if your only tape is a TF series drive,

There's an odd SCSI card (CMD 220) in it, that could be it.
A next set of tests would be to remove excess cards, and try
again.

> What does T 9E show?  On other/older machine this lists the selftests.

Here's the t 9e.
Noticing now that one set of tests is in dec. (boot) and one's in hex. (this
one), then 59=3B, and we get 'test not shown'.
If somebodies' got a book to crack on this one that might be needed.

John A.

Test
#   Address   Name               Parameters
___________________________________________________________________________
    20052800  SCB
    2005377C  De_executive
30  2005D564  MS650_Init_Bitmap  *** mark_Hard_SBEs ******
31  2005D324  MS650_Setup_CSRs   **********
32  2005CE6C  CMCTL regs         MEMCSR0_addr *********
33  2005CE28  CMCTL_powerup      *
34  20054ECC  SSC_ROM            *
3F  2005F3A8  MS650_FDM_Addr_shorts *** cont_on_err ******
40  2005FB90  MS650_count_pages  First_board Last_bd Soft_errs_allowed
*******
41  20062CCC  Board_Reset        *
42  20054F8C  Chk_for_Interrupts *****
43  2005B268  SOC_DI_Cache_w_mem cache_config start_add end_add add_incr
******
44  2005AA9C  SOC_D_Cache_w_Mem  cache_config start_add end_add add_incr
******
45  2005A6FC  SOC_Cache_mem_CQBIC cache_config start_add end_add add_incr
******
46  2005B784  SOC_Cache1_diag_mode cache_config addr_incr ********
47  2005F920  MS650_Refresh      start_a end incr cont_on_err time_seconds
*****
48  2005EFDC  MS650_Addr_shorts  start_add end_add * cont_on_err pat2 pat3
****
49  2005EA18  MS650_FDM          *** cont_on_err ******
4A  2005E770  MS650_ECC_SBEs     start_add end_add add_incr cont_on_err
******
4B  2005E530  MS650_Byte_Errors  start_add end_add add_incr cont_on_err
******
4C  2005DFD4  MS650_ECC_Logic    start_add end_add add_incr cont_on_err
******
4D  2005DE44  MS650_Address      start_add end_add add_incr cont_on_err
******
4E  2005DC50  MS650_Byte         start_add end_add add_incr cont_on_err
******
4F  2005D9A4  MS650_Data         start_add end_add add_incr cont_on_err
******
51  20062D9B  FPA                *******
52  20055538  SSC_Prog_timers    which_timer wait_time_us ***
53  20055808  SSC_TOY_Clock      repeat_test_250ms_ea Tolerance ***
54  20055062  Virtual_Mode       *********
55  200559BE  Interval_Timer     *
58  20061924  SHAC_RESET         dssi_bus port_number time_secs
59  20060A78  SGEC_LPBCK_ASSIST  time_secs **
5A  2005A600  SOC_CMCTL          dont_report_memory_bad repeat_count *
5C  20060FE0  SHAC               shac_number *******
5F  2005FD64  SGEC               loopback_type no_ram_tests ******
60  2005A22D  SSC_Console_SLU    start_BAUD end_BAUD ******
62  20055DFC  console_QDSS       mark_not_present selftest_r0 selftest_r1
*****
63  20055F78  QDSS_any           input_csr selftest_r0 selftest_r1 ******
80  20059C0D  CQBIC_memory_LMGH  **********
81  20055A60  Qbus_MSCP          IP_csr ******
82  20055C25  Qbus_DELQA         device_num_addr ****
83  20056E82  QZA_Intlpbck1      controller_number ********
84  2005853C  QZA_Intlpbck2      controller_number *********
85  200560D4  QZA_memory         incr test_pattern controller_number *******
86  20056590  QZA_DMA            Controller_number main_mem_buf ********
87  20059780  QZA_EXTLPBCK       controller_number ****
90  200554B6  CQBIC_registers    *
91  2005544C  CQBIC_powerup      **
99  20062FA9  Flush_Ena_Caches   dis_flush_cache *********
9A  20061EB0  INTERACTION        pass_count disable_device ****
9B  20062B8C  Init_memory_4MB    *
9C  2005C02A  List_CPU_registers *
9D  2005CD06  Utility            Expnd_err_msg get_mode init_LEDs clr_ps_cnt
9E  20055A32  List_diagnostics   *
9F  200630E6  Create_A0_Script   **********
C1  20054B78  SSC_RAM_Data       *
C2  20054D4E  SSC_RAM_Data_Addr  *
C5  20059A51  SSC_registers      *
C6  20054ABC  SSC_powerup        *********
C7  20059B58  SSC_CBTCR_timeout  ***

Scripts
#   Description

A0  User defined scripts
A1  Powerup tests, Functional Verify, continue on error, numeric countdown
A3  Functional Verify, stop on error, test # announcements
A4  Loop on A3 Functional Verify
A5  Address shorts test, run fastest way possible
A6  Memory tests, mark only multiple bit errors
A7  Memory tests
A8  Memory acceptance tests, mark single and multi-bit errors, call A7
A9  Memory tests, stop on error
B5  Cache tests, report errors

---

From: "John Allain" <[email-masked]>
Date: Mon Jun 23 16:10:34 2003

The machine seems usable now.
It's flaky in a way I don't understand.
Both the PSU's have green lights on them but when 
it comes up it autoreboots at test 60.. continuously for
a reason I have to determine someday.
Until then it seems to be OK if I halt the boot, wait about
four minutes and then restart.  It goes all the way to boot
3.. and then takes the 'b dia0', and 'sho dssi'.  Whatever.

Anyone recognizing the symptoms can add a message.
Till then.

John A.

---

From: "Antonio Carlini" <[email-masked]>
Date: Mon Jun 23 16:16:11 2003

> Noticing now that one set of tests is in dec. (boot) and 
> one's in hex. (this one), then 59=3B, and we get 'test not 
> shown'. If somebodies' got a book to crack on this one that 
> might be needed.

You can search at http://vt100.net/manx if you want a goodly
selection of relevant manuals. "KA660" and "VAX 4000 200"
will pull up the relevant manuals.

Happy reading.

Antonio
 
-- 

---------------
Antonio Carlini             [email-masked]