Subject: re: Victor Keyboard Identification

From: Thomas Martin <[email-masked]>
Date: Wed Apr 2 02:58:31 2003

Rob,

It's an enhanced keyboard from a Victor 9000 system.
They were built in the early 80's and were pretty good
machines. 80 track 5.25" disks held 1.6MB and ran
CP/M-86 or MS-DOS. 800x400 graphics mode, although
most were monochrome.

You can also see them labeled as Sirius machines from
time to time.

Tom

>>Hi All,
>    Can anyone help me identify what machine this
>keyboard goes to:
>http://idisk.mac.com/colourfull_creations/Public/victor.jpg

>It's from Victor Business Products. It says Model 703
>on the bottom. It 
>also has a keyboard cable with an RJ-45 plug on it.

>I just acquired it this weekend. I only have the
>keyboard not the 
>machine.

>Thanks
>Rob

=====
----------------------
"I drank what?!" - Socrates

Thomas Martin
[email-masked]

---

From: John Honniball <[email-masked]>
Date: Fri Apr 4 12:11:00 2003

> You can also see them labeled as Sirius machines from

Yes, I'd have called it a Sirius keyboard!  Mine are darker in colour,
though; dark grey instead of beige.  I have a spare Sirius I, if anyone
in the UK would like one -- as designed by Chuck Peddle.

--
John Honniball
[email-masked]