Subject: Re: Data Systems Design DSD-880 8" floppy and hard drive?

From: <[email-masked]>
Date: Wed Jul 23 19:57:36 2003

Jerome Fine <[email-masked]> wrote:

> I agree there needs to be a SYSGEN to be able to use
> all 3 * RL02 drives with the DL(X).SYS device drivers
> and the hardware handles ONLY 18 bit addresses for
> both the DYX.SYS  and DLX.SYS device drivers.
> 
> BUT the RLV11 and the RXV12 from DEC also
> managed to handle only 18-bit addresses.  So the
> DSD box was completely compatible with the stock
> (distributed) V4.00 of RT-11.
> 
> However, V4.00 code in DY.MAC contained the
> extra instructions to use a double-sided media which
> would probably have been called an RX03.  And
> although those extra instructions had bugs (after all
> they had never been tested) and were removed by
> V5.00 of RT-11, I did fix the bugs and ran a DYX.SYS
> device driver under V5.03 of RT-11 using the DSD
> 8" floppy as a double-sided drive.  In addition,
> I also added a bounce buffer in DYX.SYS so that
> a user buffer above 256 KBytes could be used
> with the 18-bit hardware addresses in the floppy.

   Actually, for device I/O, it doesn't matter whether 
one is using 16, 18, or 22 bit addressing.  The PDP-11 
I/O page is defined as from 28KW-32KW, which is entirely 
within the range of 16bit addressing.

Dale Rogers 
DEC/Compaq/HP

---

From: "Fred N. van Kempen" <[email-masked]>
Date: Wed Jul 23 20:18:45 2003

> within the range of 16bit addressing.
No, because the MMU maps this space from the upper 4KW in
*virtual* space (the visible 64KB space the CPU can address)
to the upper 4KW in *physical* space, meaning:

16b:	28-32K
18b:	124-128K
22b:	2044-2048K

Depending on how the OS maps its ring-0 address space, this
might not matter directly to the software.  However, devices
doing DMA need to know the *physical* address of the buffer
in memory, not the virtual one :)

So.. DMA devices are usually the cause of trubs with 16/18b
addressing in 22b systems.  Try installing an RK11 in an
11/44 or 11/70 and do NOT do anything special :)

(yes, that's why they came up with the Unibus map...)

--f

---

From: Peter Turnbull <[email-masked]>
Date: Wed Jul 23 20:20:26 2003

On Jul 23,  1:34, <[email-masked]> wrote:
> > [...]  In addition,

It's true that the I/O page always appears *to software* at *logical*
addresses 160000-177777.  This is fine for the processor, which has
logic to deal with it.  Nevertheless, the *hardware* addresses which
appear on the bus need to be 160000-177777, 760000-777777, or
17760000-17777777 depending on whether the system uses 16, 18, or
22-bit addressing.  To make life easier, DEC provide a "Bus Bank Select
7" signal, which most I/O devices use to detect access to the I/O page.

What Jerome is referring to, however, is the DMA operation.  An RXV21
or RLV11 (and some other devices) can only perform data transfers to
18-bit addresses.  Data is transferred only by DMA; you can't transfer
data from the device controller, only commands and status.  Most DEC
operating systems expect data transfers to be able to load/save from
data buffers at arbitrary (physical) addresses; therefore drivers in
some operating systems have the option to use a bounce buffer mapped to
low memory, for 18-bit devices.  They therefore transfer the data in
two stages: under program control between the bounce buffer and the
required address, and letting the DMA transfer between bounce buffer
and actual device.

-- 
Pete						Peter Turnbull
						Network Manager
						University of York