Subject: Re: H89 disk formats?

From: "Dwight K. Elvey" <[email-masked]>
Date: Fri May 2 01:20:36 2003

>From: "Don Maslin" <[email-masked]>
>
>On Tue, 29 Apr 2003, Dwight K. Elvey wrote:
>
>> Hi
>>  I've been looking at a pile of disk that I'd
>> collected over a period of years. Most are the
>> typical 10 hard sectored disk, formatted in the
>> same way as HDOS uses. In the pile, I found a
>> few that are marked "format 96". These have the
>> 10 plus index holes but they don't seem to be
>> the normal format. When I attempt to read them,
>> I can only read the first sector. All of the rest
>> don't seem to read. Does anyone know what this
>> was all about?
>> Dwight
>
>Dwight, I would assume that they were done on a 96tpi
>floppy drive.
>						- don
>

Hi Don
 That is what I figured. I've been working on my serial
bootstrap and transfer program. I'm able to read and
write an image to the H89 but I'm still having issues
getting the formatting to work. I copied some old
code that I have in the Fig-Forth that I did but it
is still missing something. I even went back and ran
the Forth FORMAT and it works fine. I suspect there is
some other initialization that I'm missing. I looked at
one stretch of code and there is an operation that should
always hang. Can't figure why the original works. It
may be something connected to the timer interrupt that
isn't normally there. I wish I'd made good notes when
I did the original but this was one of my first computer
projects, after working on my Poly88, and brain rot
is now catching up with me.
 Once I get the format working, I can work on cleaning
up the user interface. Looking at the 96 stuff is a
little later on the list.
Dwight

---

From: "Patrick Rigney" <[email-masked]>
Date: Sun May 4 01:26:10 2003

Dwight,

I was going through a stack of HUG diskettes last night just taking stock of
what I have, and lo and behold, I have a utilities disk with a HUG-modified
H-17 driver that supports two-sided 40- and 80-track drives (hard sector
still, of course).  Judging from the instructions, it seems that basically
replacing SY.DVD on a disk with this new driver (and of course, having the
right drive in the machine) would get it working.  It seems plausible that
the disk could have been made on a system with this driver. It comes with
assembly source as well, and even versions for machines upgraded to 3- and
4-Mhz operation.  No mods to the controller itself appear to be necessary.
Let you know if you'd like a copy.

Patrick