Subject: RE: Atari ST spares

From: Al Hartman <[email-masked]>
Date: Thu Mar 6 13:06:49 2003

From what I remember, the floppy select signals and
Parallel port are all driven from the Yamaha sound
chip.

Atari decided to save a couple cents on each machine
by not buffering the select signals. They are pretty
dicey so that if you hook up a generic 720k Floppy
drive, you sometimes have trouble with them.

There was a mod that would add the buffering to the
sound chip.

I'm looking for it myself to put in my own unit. As
I'm using two external DS 720k drives on it rather
than the SS 360k Atari Drive.

Drive mechanisms have been known to go bad on the
ST's. They weren't the highest quality mechanisms.

Try getting a generic 720k drive and putting it on...

Is this an internal or external drive?

Regards,
Al Hartman

> From: "Witchy" <[email-masked]>
> > > but it appears that the floppy is toast since it
> > > continually tries to seek track 0 and won't
> > > read/write even Atari format disks.

> > I'm not shure, but wheren't the floppy select
> > signals also generated by the keyboard controller?

> They were/are on the Amiga (Paula) but I'm not sure
> about the ST. I'm hopefully getting another ST this
> week, and I'll also play swapsies with the museum's
> ST to see if the keyboard is breaking the floppy.
> Nobody mentioned that on comp.sys.atari.st though.
>
> cheers
> --
> adrian/witchy
> www.binarydinosaurs.co.uk - the online computer
> museum
> www.snakebiteandblack.co.uk - monthly gothic
> shenanigans

---

From: "Witchy" <[email-masked]>
Date: Fri Mar 7 16:26:57 2003

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Al Hartman
> Sent: 06 March 2003 15:54
> To: [email-masked]
> Subject: RE: Atari ST spares
>

You're right there! Having said that the drive I dug out could have been bad
itself; it was in the big box of spares the missus brought back when she
left her IT technician job 3 years ago and was untested.

> Is this an internal or external drive?

Internal.

The keyboard damage and subsequent repair is interesting since I don't see
how it could've happened without breaking either the case or the keys
themselves; it's like something's punched right through the circuit board
and physically broken it, enough to push a section of it out by 2-3mm, and I
don't believe that someone would go to the trouble of replacing the top
section of the keyboard AND repair the circuit board.
The hole's been shored up with a hot glue gun and the tracks replaced with
nice blue wires soldered in....

--
adrian/witchy
www.binarydinosaurs.co.uk - the online computer museum
www.snakebiteandblack.co.uk - monthly gothic shenanigans

---

From: [email-masked] (Tony Duell)
Date: Sat Mar 8 02:30:32 2003

> nice blue wires soldered in....

Had this been a TRS-80 M3 or M4, I could understand it. There's a plastic 
post in the case that seems to be designed to punch a nice hole in the 
keyboard PCB (a horrible SRBP thing) if you drop something heavy on the 
keyboard. Please don't ask how I discovered this ;-)

-tony