Subject: Re: Wanted: iUP201 modules

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon Mar 3 22:37:56 2003

Hi Joe
 When I was back at Intel, I was responsible for the test
used by the system test on the UPP units. I can tell you a
little bit about them.
 First, I have no idea what a "upgraded the RAM memory"
means. These used 4002's. These work on the 4004/4040
bus. They are completely incompatable with other types
of RAM's and they also have input ports on them ( or
maybe it was output but I think it was inputs ).
The internal orginization is not compatable with ordinary
RAM's either( not a simple power of two type addressing ).
 The main controller board has a 4040 uP with some ROM
( 4001's ). This ROM was addressed as
bank0. Each of the two slots for the personality cards
was addressed as Bank0 for slot 0 and Bank1 for slot 1.
This way, personality code could be accessed on either
bank to run the particular operation. The code on the
controller board ran the handshake with the parallel
port to the Intelec system.
 I wish that I'd saved the schematics I'd had at Intel
but I was not as smart then. I'd also made a board that
I'd plugged into a Intelec system in place of the 4040.
It allowed me to test the hardware and compare ROM code
to make sure every thing was correct. This is also long
gone.
 I once even had the ROM code for these.
Dwight

>From: Joe <[email-masked]>
>
>Hi Robert,
>
>   Do you have any info on the internal hardware for the 201?  I have one 
that's dead.
>
>   Joe
>
>
>
>At 12:01 PM 3/3/03 -0500, you wrote:
>>Just resurrected my Intel iUP201 Universal Programmer,
>>and am writing the control software for it (which will be
>>available for free).
>>
>>I'm wondering if anyone out there has any modules for it
>>that they want to get rid of?  I currently have the
>>2708/2716/2732...27128 module and the 27128/27256 module.
>>I've also upgraded the RAM memory on the programmer.
>>
>>I'm in Ottawa/Ontario/Canada, but will pay shipping worldwide.
>>These things are pretty light.
>>
>>Thanks,
>>-RK
>>
>>--
>>Looking for Digital Equipment Corp. PDP-1 through PDP-15 minicomputers!
>>Robert Krten, PARSE Software Devices +1 613 599 8316.
>>Realtime Systems Architecture, Consulting and Training at www.parse.com

---

From: Dave Mabry <[email-masked]>
Date: Mon Mar 3 22:38:03 2003

Dwight and all,

The UPP was the 4040-based eprom programmer.  Joe and Robert are talking 
about the iUP-201.  It's been a long time, but I also upgraded the 
memory on mine.  I doubled it.  I think from Intel it could have either 
of two sizes of ram chips populating it.  Probably a jumper or such to 
change it from the smaller chips to the larger ones.  Sorry to be vague 
about it, but I seem to only be able to remember bits and pieces of that 
life.  Just ask Joe!  ;-)

Dwight K. Elvey wrote:
> .

-- 
Dave Mabry             [email-masked]
Dossin Museum Underwater Research Team
NACD #2093

---

From: Joe <[email-masked]>
Date: Mon Mar 3 22:38:44 2003

Dwight, 

   Are you sure that you're not thinking of the older UPP-103 EPROM programmer?  I know that it uses a 4040 but IIRC I've opened up an iUPP-201 and I THINK it used an 8085.  The iUPP-201 looks kind of like a calculator with a keyboard on the right side and a single line LED display above it. On the left side next to the keyboard is large socket for the personality adapter. The personality adapter has the socket for the EPROM or other device to be programmed. The older iUPP-103 looks like a box with a sloping front. It has two EPROM sockets on the right side. The personality is controlled by cards that go inside the box.  FWIW I picked up several more iUPP-103s with the massive load of intel stuff that I got just before Christmas. I found some of the cards for them but alas no CPU cards.  Need any parts?

   Joe

---

From: Joe <[email-masked]>
Date: Mon Mar 3 22:38:48 2003

>about it, but I seem to only be able to remember bits and pieces of that 

   I know that the iUPP-201 came with 32k of RAM and IIRC it could be upgraded to 64k. IIRC it uses an 8085 CPU.

      Joe