Subject: Re: Northstar File Transfer from PC

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon May 5 22:13:16 2003

Hi Marvin
 Maybe this isn't exactly what you are looking for
but I'm currently working on some software to transfer
entire disk images through the serial port of a H89
to a PC. I have another friend checking out my first
version, now. I hope to do a similar things for the
N*'s as soon as I get one of these machines up and
running ( on my list of things to do ).
 I suppose that once the image is on the PC, one can
modify the image to include any new files, one wants
and then transfer it back to the N*. It isn't a nice
direct method but my main intent is to get some way
to send disk images over the net and not specifically
individual files.
 I haven't fiddled with the N* at all and don't
know a lot about it. The H89 has a simple monitor that
I use to hand enter a simple bootstrap program. With
this, I bring in the rest of the code to run the disk
drive. Does the N* have a ROM based monitor?
 I also have a similar setup for my Poly88 but that is
setup for getting code into the Poly88 and tape from the PC.
I used this to create code to do the various tape
copying functions. I can read code from a cassette
tape, transfer it through the serial to the PC and
later feed it back through the serial to the Poly88
to write back onto tape. I use a similar bootstrapping
code to get things started, through the Poly's monitor.
Dwight

>From: "Marvin Johnston" <[email-masked]>
>
>What is the procedure for transfering files to and from a PC using N*
>DOS? For text from the N* to the PC, no problem, just print it out to
>the terminal (a DOS machine) and capture it. But what about going the
>other way, wanting to get information back to the N*? Any information
>appreciated!
>
>-------------------------------------------
>ebaY's Security Breach and Coverup
>http://www.auctionguild.com/generic110.html

---

From: Marvin Johnston <[email-masked]>
Date: Mon May 5 22:13:25 2003

Hi Dwight,

Being able to transfer disk images would be a good thing! The monitor on
the N* is on the disk, and I don't *think* there is one built into ROM
... at least on an unmodified machine. And I believe the monitor is also
a N* DOS program as opposed to something on the CP/M disk, but I'll have
to check that to be certain. The CPU board does have provisions for
adding an EPROM but I'm not certain how it is accessed. Somehow I've
misplaced a box of N* stuff that had a lot of utilities. *Hopefully*, my
HD is still readible although I haven't accessed it in many years. If
not, oh well :).

--