Subject: Re: breathing life into old chips

From: Jochen Kunz <[email-masked]>
Date: Fri Apr 4 12:39:05 2003

On 2003.04.04 11:04 Jules Richardson wrote:

> the microcontroller in the set seems to have developed a fault 
> which only appears when the set's warm. 
Are you sure it is the microcontroller? Problems of this kind are "cold"
solder points much more often then failed components. => Resolder
everything on the PCB, especially where the PCB gets hot. 
-- 

tschüß,
       Jochen

Homepage: http://www.unixag-kl.fh-kl.de/~jkunz/

---

From: [email-masked] (Tony Duell)
Date: Mon Apr 7 12:40:22 2003

> hi,
> 
> this is sort of off-topic as it applies to my TV and not a computer, but I bet
> some of the folks here can offer advice... :)
> 
> the microcontroller in the set seems to have developed a fault which only
> appears when the set's warm. Tracking down a replacement seems to be easier

Possible. I assume you've checked for dry joints, that the IC's power 
supply is good (check decoupling caps too), that the reset line is right, 
and that the crystal is good (a suprising number of crystals fail in TVs...)

> said than done as the chip was obviously discontinued a while back (and then
> I'd have to worry about the on-board ROM anyway).

Have you tried a TV spares place? You might still be able to get the 
original part, correctly programmed.

> 
> At the moment though there's no heatsink on the chip - if I do stick a heatsink
> on it in the hope that it keeps it cool enough to operate, is it still likely
> to fail at a later date anyway? Once a chip's started to exhibit heat-related

In my experience it will get worse :-(

-tony