Subject: MT-80Z Micro Professor Manuals

From: "Washburn, Larry CIV" <[email-masked]>
Date: Thu Jul 17 14:12:05 2003

Glen

Noticed your posting about the missing manuals for the E&L z80 trainer.
I am also in same boat,  just  won mine on ebay,,, minus  manuals  etc

Did you ever locate any manuals, experimenter books for the unit?

Larry

---

From: Joe <[email-masked]>
Date: Mon Jul 21 15:12:56 2003

Larry,
There was a set on E-bay just a week or two ago.

   Joe