Subject: HP 1650B Logic Analyzer Flexible (Floppy) Disk Drive Pinout

From: "Pholink" <[email-masked]>
Date: Fri May 16 10:31:57 2003

HI:

    Does everyone have experience connect 3.5" PC floppy disk drive to HP 16XX
logic analyzer? I think the HP used 720K floppy disk. It is different from
standard PC floppy disk. He is pintout on HP main board.

1   ?
2    ?
3,5,6,7,9,11,12,14    5V
4, 16 ?
8 ?
13,15,17,19,21,23,25,27  GDN
18 ?
20 ?
22 ?
24 ?
26 ?
28 ?
30 ?
32 ?
34 ?

29, 31,33   12V

Would you tell me what "?" is?

Thanks

LI

---

From: Joe <[email-masked]>
Date: Fri May 16 10:32:05 2003

I'm not sure what drive the 16xx is supposed to use but ALL of HP's HP-IB
disk drives use 600 RPM drives and a much higher transfer rate than
standard PC type 3.5" drives. a PC drive will not work in them, PERIOD.  I
believe the built-in drives that HP uses are the same but I'm not positive.

    Joe

---

From: [email-masked] (Tony Duell)
Date: Fri May 16 10:38:48 2003

> standard PC floppy disk. He is pintout on HP main board.

This may be a Sony MP-F52W-50 drive. That drive is used in the 9114B and 
9153 drive units. The pinout matches sort-of (in that a couple of pins 
you have tied high are in fact drive select signals, but it would be 
sensible to tie them high if not used). 

> 1   Reset Disk Change/
> 2   Disk Change
> 3,5,7,9,11    5V
6 DS3/
10 DS0/
12 DS1/
14 DS2/

> 4 LED On/
16 Motor On/
> 8 Index/
> 18 Step Direction
> 20 Step/
> 22 Write Data/
> 24 Write Gate/
> 26 Track00/
> 28 Write Protect/
> 30 Read Data/
> 32 Side Select/
> 34 Ready/

I am a bit suprrised you didn't mention pin 10. This is DS0/, and could 
possibly be tied to ground in a single-drive system.

The pinout is close to that of a PC drive. But a PC drive will _not_ work 
without major changes to the controller because the HP (or Sony) drive 
rotates at 600rpm -- twice as fast.

If you have the old Sony drive, it's worth knowing that many of the parts 
(head, stepper motor, analog ASIC, motor driver chips, etc) are the same 
as in an Apple Mac 800K drive. Those are relatively common and make a 
good source of spares.