Subject: Re: Practical Electronics CHAMP/Tangerine Microtan 65

From: "Dwight K. Elvey" <[email-masked]>
Date: Sat May 24 19:39:04 2003

>From: "ben franchuk" <[email-masked]>
>
>David Comley wrote:
>
>> Since you mention it, I had been thinking about
>> designing and building a processor from scratch from
>> TTL devices. I am slowly accumulating TTL chips as I
>> come across them at hamfests and things. Perhaps it's
>> time to put pencil to paper.
>> 
>> Of course I could take the NASA Apollo Guidance
>> Computer approach and build everything welded-cordwood
>> style out of NOR gates.
>
>Nope that used lots of REAL ( expensive ) TTL.
>The neat part of that was the CORE memory used.
>
>Any how a real TTL computer is about 4+ large
>logic cards. Control card, alu card, memory card
>and serial I/O card. The mother board is bus
>and front pannel logic.
>I am doing a 20 bit CPU with about 125 chips total
>in the computer and front panel. About 50?
>more chips for memory and serial i/o.
>
>http://www.jetnet.ab.ca/users/bfranchuk/ldp/ldp1.html
>Ben.
>

Hi
 All make the assumption that you must make 8 bit/16bit
or, in your case, 20 bit. One can make a 1 bit alu that
can have data width controlled by instruction. It may
not be fast at math but much processor time is consumed
just looking at true/false. If your model doesn't require
passing data through the alu for mem/mem and mem/io moves,
a single bitter makes sense.
 ( My Nicolet is a 20 bit machine. )
Dwight

---

From: ben franchuk <[email-masked]>
Date: Sat May 24 19:39:36 2003

>  ( My Nicolet is a 20 bit machine. )

Darn!  All the good computer names are taken. :)
Do you have any more information?

> Dwight

Some day I would like to see a DECIMAL computer in
TLL or FPGA like the early decimal machines.
Ben.

---

From: "Peter C. Wallace" <[email-masked]>
Date: Sat May 24 19:40:24 2003

>  ( My Nicolet is a 20 bit machine. )

I have considered making a 1 bit stack oriented machine with 4 bit
instructions, long and short jumps and memory reference are done by pushing
the target address a bit at a time onto the pointer stack, then issuing the
jump or memory ref inst (that looks at the 1 bit pointer stack depthwise)...

Peter Wallace

---

From: [email-masked] (Tony Duell)
Date: Sat May 24 19:54:08 2003

[...]

> can have data width controlled by instruction. It may

This may not reduce the IC count that much!. I've recently been looking 
at the HP9810-series calculators, and the processor in there is a bit 
serial unit. There are 4 cards of around 20 chips each for the processor 
(control, data path, clock, I/O interface) and another 2 or 3 cards, 
again 20 chips each, for the mrmory interface. Which is easily comparable 
to a full-parallel 16 bit processor.

-tony