Subject: Re: Writing single density disks on a PC?

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon May 19 15:38:25 2003

>To: [email-masked]
>
>Ok, I want ot generate some disks for my Model 4 on my PC, BUT some of the 
>disks I want to regenerate are mixed single and double density ... any 
>suggestions?
>

Hi Geoff
 If it is done a track at a time, you can deal with it
by using the low level disk access functions of the BIOS.
You do have to have a disk controller that supports
single density ( not all do ). There are a few articles
around that describe setting up the DMA ( needed for floppies )
and the disk controller, as another option. I've found
this method to sometimes be machine dependent so if
you can get by with the standard BIOS calls, that is
a better way.
 If you can read Forth, I can send you some code I wrote
to write tracks for my Olivetti M20 ( Z8000 machine ).
I don't have a controller that does track 0 that is
single density but you can get the idea of how to handle
the controller and DMA. The other tracks are double
density ( 360K drives ). You also need a compatible
drive. You can't use a 1.2M drive to write single density
at all and double density is not properly done so
it will most likely fail to read reliably( a track width
issue ).
 It may also be that your machine is supported by things
like 22DISK. Have you tried this?
Dwight

---

From: "Fred Cisin (XenoSoft)" <[email-masked]>
Date: Mon May 19 15:38:48 2003

> by using the low level disk access functions of the BIOS.

To do either single density, or the special data address marks, you will
have to go below the BIOS level (13, 1E).  not especially hard to do, but
there can be a few minor portability issues.

> single density ( not all do ). There are a few articles

look for the 37C65 chip; but there are some others, and even the stock
5150 FDC board can be MODIFIED for SD.

> like 22DISK. Have you tried this?

Try Hypercross/PC-Xzap  from Hypersoft.
I'd like to hear from anybody who has SUCCESSFULLY used 22DISK for
anything other than CP/M, or used ANY commercial product for SD.
Yes, Catweasel or Option board THEORETICALLY could do it.
Posters about any product that "can do it", but don't differentiate
between "CAN DO" and HYPOTHETICAL POSSIBILITY can go F themseves.
(During the life of my products, I constantly competed with rumored,
but non-existent, capabilities of some products)