Subject: DEC RD54 from Maxtor

From: "Franco Tassone" <[email-masked]>
Date: Mon Mar 3 14:57:27 2003

Hi all,

unfortunatelly one of my two RD54 hd (by Maxtor) in my mvaxII kept doing
strange sounds at startup. It isn't coming on line as before, now it takes a
lot of time while a continuous noisy sound comes from it, and after it seems
sufferig of read problems at bootup.
Any info/advices about RD54 and it's strange sounds will be greatly
appreciated.
...
Franco Tassone

---

From: "John Willis" <[email-masked]>
Date: Tue Mar 4 12:43:09 2003

Hi,

The RD54 (Maxtor XT-2190) hard drive is an old ST-506 relic, and is unreliable at best. I have a VAXstation 2000 with an RD54, and
most of the time the drive won't even spin up. When it does, it makes sounds the same as you are describing here. I went in search
for a replacement, but found most resellers are getting $300+ for the RD54, as it is rare. I would reccommend looking for RD53s,
RD52s, etc., or better yet, find yourself a Q-bus SCSI controller. SCSI drives are cheap, and quite more reliable than anything
you'll find in ST-506.

You could also go the DSSI route, if you want nothing to do with *nix, or get a KDA50 and go SDI, if you have the patience to deal
with its many quirks.

You may also be able to use non-DEC ST-506 drives, but be warned: AFAIK, the only VAX that can perform a low-level format on its own
ST-506 drive is the VAXstation/uVAX 2000. It allows you to choose one of the DEC models, or enter your own drive geometry, IIRC.

Hope this helps,
John

+------------------------------------------------+--------------------------------+
| John P. Willis, MCP, SBI, NASA-STD-8739.5      | Coherent Logic Development     |
| Chief Executive Officer                        |  "Multiplatform Solutions      |
| Coherent Logic Development                     |    for a Multiplatform World"  |
+------------------------------------------------+--------------------------------+
| web: http://www.coherent-logic.com/                                             |
| e-mail: [email-masked]                                                  |
+---------------------------------------------------------------------------------+

---

From: Kevin Handy <[email-masked]>
Date: Tue Mar 4 12:43:20 2003

>RD52s, etc., or better yet, find yourself a Q-bus SCSI controller. SCSI drives are cheap, and quite more reliable than anything
In my experience, anything but an RD54 is likely to be a problem.
The RD54 usually had a two or three times longer lifetime than
the other RD drives. That is probably why RD54's are in such
demand.

If you want something for long-term usage, I'd really recommend
getting a SCSI interface, then you have a much larger choice of
media.

---

From: Ethan Dicks <[email-masked]>
Date: Tue Mar 4 12:46:04 2003

> the other RD drives. That is probably why RD54's are in such

They were also the largest DEC-supplied drive and were useful as
system disks up into the early versions of VMS 6.x (maybe not
officially, but practically - I have either 6.0 or 6.1 on an RD54
that a friend of mine built for me; dunno what he had to leave out).

I'm glad that I don't have to buy any (but I might consider swapping
one for a Qbus SCSI controller ;-)
 
> getting a SCSI interface, then you have a much larger choice of

Indeed, but if you are into vintage hardware, not always practical
(the uVAX-2000 comes to mind).
 
> >You may also be able to use non-DEC ST-506 drives, but be warned: AFAIK,
> > the only VAX that can perform a low-level format on its own
> > ST-506 drive is the VAXstation/uVAX 2000. It allows you to choose one
> > of the DEC models, or enter your own drive geometry, IIRC.

My experience with the uVAX2K ROM formatter is that you can *not*
randomly specify geometry.  You can low-level format a DEC drive, but
I'm not positive you can take a drive from a PC that has never seen
DEC use and turn it into a DEC drive (bad block table, ident tracks
and the like).

You _can_ do all these things with the Field Service formatter on a
Qbus uVAX and an RQDX3.  I have taken several Seagate, Maxtor and
Miniscribe drives from PeeCees and made them useful to DEC controllers
with the FS tape.  Given that it takes a *looong* time to load, I'm
interested in exploring the XXDP/VTserver route and a PDP-11 CPU board.
That might be less hassle.  Dunno yet.

-ethan

---

From: Megan <[email-masked]>
Date: Wed Mar 5 06:00:01 2003

>The RD54 (Maxtor XT-2190) hard drive is an old ST-506 relic, and is
>unreliable at best. I have a VAXstation 2000 with an RD54, and most of 
>the time the drive won't even spin up. When it does, it makes sounds the 
>same as you are describing here. I went in search for a replacement, but 
>found most resellers are getting $300+ for the RD54, as it is rare. I 
>would reccommend looking for RD53s, RD52s, etc., or better yet, find 
>yourself a Q-bus SCSI controller. SCSI drives are cheap, and quite more 
>reliable than anything you'll find in ST-506.

Avoid the RD53 at all costs... it is the most problematic of the
RD series drives.  The RD54 in my experience is the most
reliable, and I have a number of them in machines still
working.

Yes, going to SCSI would be nice, but you can't put one in
your VAXstation 2000... and the qbus controller for SCSI
disks is expensive... check out the auctions on ebay.  The
two most recent I've seen were $130 and $240 for UC08s.  Some
of the other SCSI controllers from third-party vendors are
even more...

>You could also go the DSSI route, if you want nothing to do with *nix, or
>get a KDA50 and go SDI, if you have the patience to deal with its many
>quirks.

Or you could try ESDI... I have a couple of machines with the
Andromeda ESDC controller and hitachi DK515-78 drives.  They
work just fine with MSCP device drivers...

					Megan Gentry
					Former RT-11 Developer

+--------------------------------+-------------------------------------+
| Megan Gentry, EMT/B, PP-ASEL   | email: mbg at world.std.com         |
|                                |                                     |
| "this space                    |             (s/ at /@/)             |
|  unavoidably left blank"       | URL:     http://world.std.com/~mbg/ | 
|                                | "pdp-11 programmer - some assembler |
|                  (DEC '77-'98) |  required." - mbg            KB1FCA |
+--------------------------------+-------------------------------------+

---

From: "Antonio Carlini" <[email-masked]>
Date: Wed Mar 5 06:00:47 2003

> Avoid the RD53 at all costs... it is the most problematic of 
> the RD series drives.  The RD54 in my experience is the most 
> reliable, and I have a number of them in machines still working.

I never had enough RD53s to form a statistically valid opinion.
Never had a problem with RD54s (and I guess I had maybe
a dozen running in the lab).

> your VAXstation 2000... 

Unless you use Wolfgang Moeller's modified ROMs - then I believe
that SCSI will work. (IIRC the modified VS/UV2K ROMs also 
incoroporate the >1GB fix ... but it's been a long time since
I looked).

Antonio

-- 

---------------
Antonio Carlini             [email-masked]

---

From: "Fred N. van Kempen" <[email-masked]>
Date: Wed Mar 5 06:01:49 2003

> > reliable, and I have a number of them in machines still working.
I have to second that.. they get stuck.  The RD54's, albeit noisy
beasts, still go here, or, at least, most of them.

(Yes, Wilko, I'll come and pick up the stuff this weekend..)

> incoroporate the >1GB fix ... but it's been a long time since
Given the DMA structure of the VS2000 SCSI port, connecting disks
to that port will be dramatically slow.

Fred

---

From: "Antonio Carlini" <[email-masked]>
Date: Wed Mar 5 06:02:30 2003

> Given the DMA structure of the VS2000 SCSI port, connecting 
> disks to that port will be dramatically slow.

So which aspect of the VS2000 would you describe
as fast then :-)

Actually, when used as an Xterm (by booting the VAXELN based
VXT code - or its predecessor) it was not too bad. At least,
compared to what was available then!

Antonio
 
-- 

---------------

---

From: "Fred N. van Kempen" <[email-masked]>
Date: Wed Mar 5 06:02:40 2003

> So which aspect of the VS2000 would you describe
Uhm.  The power supply comes up REAL quick after powerup :)

> compared to what was available then!
I would if I could, you (censored).
(quoting Eric Cartman)

Seriously.. I'd like to see the graphics on the 2000, but I lack
the keyboard/mouse thingie.  I believe there's a cable that ends
in a little box, in which you could plug the mouse and keyboard,
much like the one used with the DS5000 series.

I _do_ have two 2000's, soo..

(one MicroVAX 2000, and one VAXserver 2000.. anyone in NL have a
VAXstation 2000 for me? :)

--fred (reading :)

---

From: "John Willis" <[email-masked]>
Date: Wed Mar 5 06:02:44 2003

sorry i spoke...

---

From: "John Willis" <[email-masked]>
Date: Wed Mar 5 06:02:50 2003

You can turn the uVAX 2000 into a VS2000 by changing a jumper on the system board.

---

From: Jochen Kunz <[email-masked]>
Date: Wed Mar 5 06:02:55 2003

On 2003.03.04 20:39 Antonio Carlini wrote:

> that SCSI will work. 
I have the patched ROMs in my VS2k and indeed, it is able to boot from
SCSI disks connected to the tape port. When we tried this for the first
time it worked with VMS. I tried it with NetBSD, but NetBSD faild as the
second stage boot loader doesn't know to handle the VS2k SCSI adapter. 

> (IIRC the modified VS/UV2K ROMs also incoroporate
> the >1GB fix ... but it's been a long time since I looked).
Don't know about that. I mounted an old 650 MB 5.25" FH Seagate HD in my
VS2k. 
-- 

tschüß,
       Jochen

Homepage: http://www.unixag-kl.fh-kl.de/~jkunz/

---

From: "Fred N. van Kempen" <[email-masked]>
Date: Wed Mar 5 06:03:10 2003

> You can turn the uVAX 2000 into a VS2000 by changing a jumper
I know, but I'm one of those purists (or morons, depending how
you look at it..) who want their systems to also have the right
labels.  Meaning, I want a box with the VS2000 faceplate :)

--f

---

From: "Jerome H. Fine" <[email-masked]>
Date: Thu Mar 6 13:01:15 2003

>Megan wrote:

> work just fine with MSCP device drivers...

Jerome Fine replies:

I have used both the Hitachi DK515-78 and the DK516-15 drives
with an RQD11-EC  ESDI controller from Sigma.  I must be missing
something.  The larger DK516-15 drive (1.2 GBytes) is very slow -
about a third of the speed of the DK515-78.  I suspect that I need
to interleave the sectors, but I have not been able to find a setting
to do that with the RQD11-EC.

In addition, I am normally able to compare one RT-11 partition on
one DK515-78 drive against a different but identical RT-11 partition
on a second DK515-78 drive in about 4 minutes and 11 seconds.
For those who don't know, an RT-11 partition is 32 MBytes.
I use BINCOM in that case and the CPU is a PDP-11/83 in a
BA123 box.  However, when I have more than 7 quad boards
in the backplane, the compare time increases to about 10 minutes.
I suspect that the problem is that my system is on the very edge
of some hardware condition which causes everything to slow down,
the same problem perhaps as with the DK-516-15 drives.  Can
anyone suggest what could be causing the difficulties?  The system
is about the same when I use a PDP-11/73 and normal memory
except that I don't seem to remember having a problem when
there were more than 7 quad boards and I used the DK-515-78
drives.  But the DK516-15 drives are always very slow.

Sincerely yours,

Jerome Fine
--
If you attempted to send a reply and the original e-mail
address has been discontinued due a high volume of junk
e-mail, then the semi-permanent e-mail address can be
obtained by replacing the four characters preceding the
'at' with the four digits of the current year.