Subject: Amstrad PPC640 expansion ports

From: Kirone dal portatile <[email-masked]>
Date: Mon Apr 14 12:50:43 2003

Hi, I've found this

http://www.classiccmp.org/pipermail/cctech/2002-July/000553.html

searching for technical specs about the expansion ports of the PPC640.
In it you write "I have both the (software) technical manual and the service 
manual."

Can you please look at the manuals, for the pinout of expansion ports A anc B?

My interest is about this statement:
"2) The PPC has an expansion bus which can be turned into normal 
PC-compatible (8 bit) slots, so you can have an external display adapter"
The expansion bus is the ISA-8bit bus? Can I use it (rewiring it) for connect 
a ISA card?

TIA, and sorry for my English. ^_^;

-- 
The disadvantage of working over networks is that you can't so easily go into 
someone else's office and rip their bloody heart out. (Jim McDonald)

---

From: [email-masked] (Tony Duell)
Date: Tue Apr 15 21:30:26 2003

> In it you write "I have both the (software) technical manual and the service 

This is a fairly large mailing list, but I suspect it was me who said 
that. In any cas, I do have those manuals...

> Can you please look at the manuals, for the pinout of expansion ports A anc B?

Sure, here you are.

Expansion A (DB25)
1 +5V _input_
2 T/C
3 A19
4 A17
5 A15
6 A13
7 A11
8 A9
9 A7
10 A5
11 A3
12 A1
13 AEN
14 Ground
15 DACK0/
16 A18
17 A16
18 A14
19 A12
20 A10
21 A8
22 A6
23 A4
24 A2
25 A0

Expansion B (DC37)
1 -20V
2 IRQ2
3 IRQ4
4 IRQ6
5 I/O Rdy
6 DACK2/
7 I/O CHCK/
8 DRQ2
9 CK14 (Osc)
10 MEMR/
11 I/OR/
12 ALE
13 D7
14 D5
15 D3
16 D1
17 -5V input
18 -12V input
19 Ground
20 +12V Input
21 IRQ3
22 IRQ5
23 IRQ7
24 DACK1/
25 DACK3/
26 DRQ1
27 DRQ3
28 MEMW/
29 IOW/
30 RESET (out)
31 CK4 (Clock)
32 D6
33 D4
34 D2
35 D0
36 +12V input
37 +5V input

Note that the power lines are inputs -- the machine is powered from the 
expansion unit, not the other way round. Many of the signals come from 
irreplaceable custom chips, and should be buffered (Amstrad suggest using 
a 74HC244 for this). In particular, the following 16 signals need to be 
buffered : A0-A7 IOW/ IOR/ MEMW/ MEMR/ ALE RESET CK14 CK4  The data bus 
should be pulled high by external 10k resistors.

> The expansion bus is the ISA-8bit bus? Can I use it (rewiring it) for connect 

You can connect an 8 bit ISA card by matching up the signals, but I would 
still advise buffering the 16 signals I mentioned. Note that you need to 
provide an external PSU as well.

-tony