Subject: Need manual for Tek 922 scope

From: [email-masked]
Date: Sat May 24 19:37:46 2003

Anybody got one?  I'll pay for copying costs, postage, time, trouble,
etc., etc.

TIA --

Glen
0/0

---

From: [email-masked]
Date: Sat May 24 19:39:20 2003

I have the T921/922 SVC manual make offer

Larry