Subject: Re: H89 CP/M hard-secored boot diskette

From: "Dwight K. Elvey" <[email-masked]>
Date: Wed Apr 2 03:26:14 2003

>From: "ben franchuk" <[email-masked]>
>
>Dwight K. Elvey wrote:
>
>>  It has been a while since I had the machine running. I can
>> fire it up and check what I have. The only issue I have for
>> making copies for others is the media. I only have a few
>> hard sectored disk. For some reason, I thought that disk
>> formats would last at least as long as 33 lp records. I
>> didn't realize at the time that media was being obsoleted
>> as fast as it was produced. I know better now.
>
>The funny thing some small record companies still produce
>records.You can still get records, but not the crappy $7.95 k-tell
>stuff, but higher priced and higher quality audio.A good
>record changer and other assorted parts ( like a clean record)
>is better music wise than any CD.
>
>Can a regular disk be punched to make hard sectored disc?
>Ben.
>

Hi Ben
 Yes, one can take normal disk and punch them. They do
need to be accurately done. I've been looking at setting
up an index wheel to do just this. I have need for
doing it on 5-1/4 and 8 inch so it is an interesting
problem. One of my 8 inch applications has index holes
on the outer diameter of the disk.
Dwight

---

From: "Dwight K. Elvey" <[email-masked]>
Date: Fri Apr 4 12:10:05 2003

>From: "Don Maslin" <[email-masked]>
>
>On Tue, 1 Apr 2003, Dwight K. Elvey wrote:
>
>> Hi
>>  As I mentioned earlier, I have a Forth that runs standalone
>> on hard sectored. Since it is standalone, I've used it to
>> make exact copies of other disk. I've done things like changing
>> the interleaving to make about a 10X improvement in load
>> speeds for many programs.
>
>Is it available for download, Dwight?
>
>						- don

Hi Don
 Not yet but it could be. Since it is a standalone, I don't
know how one could easily transfer it with HDOS. Still,
I think I can come up with a simple serial to disk boot
strap that would allow one to dump it from a PC onto
the H89 disk, through the serial port of the H89. I've
done this for several other processor ( like my Poly88
for tape images and my IMSAI to bring it back to life ).
 It has been a long time since I've looked at the disk
EPROM's access methods. I'm sure I can figure it out and
get something going. That way you could save the disk
as an image file and all one would have to do is enter
a small boot strap program from the monitor to get it
going.
 I've always felt that this was the way you should be
maintaining the library since it is simpler than sending
media around the world. It does require that the machine
in question have a code monitor or possibly a location to
install a bootstrapping EPROM at worst.
 In any case, it would be good to get my Forth and the HDOS
stuff I have transferred to something that can be easily
distributed.
Dwight

>>  Anyway, if I can get it all running, I'll make copies
>> if someone supplies media.
>> Dwight
>
><snip>

---

From: "Dwight K. Elvey" <[email-masked]>
Date: Fri Apr 4 12:12:12 2003

>From: "Patrick Rigney" <[email-masked]>
>
>> Hi
>>  Old dry grease is quite common on these old drives, as
>> well as slight corrosion on the guide bars. You should
>> be able to relube and get it running, without changing
>> the stepper settings.
>>  As I recall, the H89's came with one of the snail track
>> type positioners. The biggest problem would be the guides.
>> Dwight
>
>Dwight, yes, the mechanism is very stiff, and I hope a little careful
>lub'ing may restore its health.  Now that I think about, though, I wasn't
>very smart by trying as many diskettes as I did... hopefully I didn't
>strain/burn/damage the stepper during my experimentation.

Hi
 You don't have to worry about the stepper. These draw almost
the same power if they are stalled or moving. Especially
at the slow speeds used for a disk drive.
Dwight

>
>This drive is worm gear rather than snail track.  It's one of the drives
>with the gigantic door that covers almost the entire face of the drive...
>Siemens FDD100-5.  I think this is the drive that's original to these
>beasts, so I'd like to keep it alive if I can.
>
>Patrick

---

From: "Dwight K. Elvey" <[email-masked]>
Date: Mon Apr 7 23:40:26 2003

>> Hi All
>>  Well, I dug out my H89. I turned it on, POP, turned it
>> off. Smoke comes from the one side.
>>  Well, it looked like one of the 2.2 uf tantalums decided
>
>Oh yeah... that's fully the behavior of the "popcorn" machine I referred to
>earlier.
>
>>  Years ago, I'd place a second drive in the machine by
>> installing two half height drives. The boot drive it
>> behind the other drive so I can't see what the difficulty
>> is with the other disk.
>
>I just bought a handful of half-height drives and was about to launch into
>this myself.  Did you feel a need to upgrade anything in the power supply
>before doing this, or is it up to running both motors simultaneously if/when
>that occurs?
>
>Patrick
>

Hi Patrick
 I used it this way for a number of years without any problems.
I do have the drives setup so that the select turns the motors
off when not being accessed. I believe this is the same as the
original. This is a jumper select on most drives.
 I did have to file a little material from the bezel where the
drives fit into the front. Other than that it was reasonable.
You can't see this with the drive installed.
 You do need to make sure that all of the shielding is put back
in. It is close to the yoke of the tube and needs to be protected
from the stray fields( writes will fail ). I don't recall if I
had to drill any more mount holes but I'll know more as I debug
my disk spinning problem. Of course, you need a new cable
( easily made ) and an extra power connector.
 Make sure that only one drive has the terminator( this is often
missed by many ). The controller was originally setup to run
3 drives, one inside and two outside. Dual drives are handy.
Dwight