Subject: Quantum Lightning 540 AT Hard Disk

From: Jules Richardson<[email-masked]>
Date: Wed Jul 30 23:03:51 2003

> I have an old Quantum Lightning 540 AT hard disk
...
> However, now, having tried to install the drive in a
> more modern machine to archive the data to CDR, the
> drive while recognized by the machine and the drive
> itself spinning up and apparently working returns a
> "hard disk read failure" error.

Well it has drive to the spindle motor by the sounds of it. Whether the head
assembly is intact is another matter. 

I think you can swap the boards on these things and expect them to still work -
so using the combination of your chassis / motor / platter assembly and the
logic board off a good drive might be enough - unless it is a fault in the head
assembly. 

I have a Prodrive LPS 540AT in front of me right now which is likely the same
thing as a Lightning. There seems to be just the one ribbon cable connecting
the logic board to everything so a swap wouldn't be tricky and might cure
things. Those drives used to be everywhere at one point so finding one
shouldn't be too hard.

Do double-check your drive cabling and BIOS settings (assuming it's a PC you're
hooking up to) etc.  - modern PC's seem to have a few billion settings for the
disks and probably think you're using a new drive; they may make incorrect
assumptions about data rates etc.

> Can anybody point me in the direction of any good
> information regarding the testing/diagnosis/repair of
> head-disk-assembly problems?

I know Western Digital used to release diagnostic utilities for their drives
and held them on their website; there may be similar Quantum ones floating
around.

cheers

Jules

=====
Backward conditioning: putting saliva in a dog's mouth in an attempt to make a bell ring.

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

---

From: Roger Bisson <[email-masked]>
Date: Thu Jul 31 21:02:58 2003

Firstly - thanks for the advice, folks. I'll try to
apply some of this. 

The drive spins up. And it "rattles" the heads upon
startup - presumably positioning itself over cylinder
0 (or whatever).

The disk wasn't being detected at all on the test
machine, but when tried on a different (older) machine
the disk was detected. I personally have never seen
"conflicts" between host controllers and ATA disk
drives.

I have tried diagnostics on the drive using Maxtor
(new owner of Quantum) PowerMax. It says that the
drive is all okay except for a non-existent partition
table.

When I use Active Partition Recovery (demo version),
it shows the sectors of as being all zeroes. As a
result, I'm not entirely sure whether the disk does
actually contain only zeroes in these sectors, whether
the heads might have inadvertently written zeroes to
the disk somehow or whether the heads are just giving
poor information.

I would assume that some degree of error checking is
done by the drive, but also assume that it is
something like parity checking in which case all
zeroes is viewed as being correct from the drive
electronics point of view.

If the heads are working, then it is perhaps a case of
either the heads are being lined up poorly. Do these
things need calibration? I personally doubt this as
one of the main advantages of the voicecoil design
compared to stepper motor design is the ability of the
drive to self-calibrate.

You are correct in saying that the controller boards
can be swapped, although the model and revision
numbers have to match: Maxtor sent me a confirmation
of "compatible drive electronics" and it appears that
to swap the electronics I have to find another
Lightning, although I suspect that if the heads need
replacing I can perhaps get away with using the
actuator/heads/voicecoil from a "related" drive such
as the Prodrive LPS. (The Lightning is a Prodrive LT).

These things should be readily available, but I will
probably have to lurk on ebay for a while to find one.

At this stage, I am wary of doing too much to the
drive without at least testing whether it is the heads
or the electronics that are at fault. Does anybody
know how to diagnose head faults?

Do HD manufacturers make service manuals available?
Surely they must give/sell them to HD recovery
facilities?

Thanks,

Roger

 --- Jules Richardson <[email-masked]>
wrote: > > I have an old Quantum Lightning 540 AT hard
disk